aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-devtools/gdb/gdb_7.11.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.11.bb b/meta/recipes-devtools/gdb/gdb_7.11.bb
index f02e6431dd..57cffc9983 100644
--- a/meta/recipes-devtools/gdb/gdb_7.11.bb
+++ b/meta/recipes-devtools/gdb/gdb_7.11.bb
@@ -3,6 +3,11 @@ require gdb-${PV}.inc
inherit python3-dir
+EXTRA_OEMAKE_append_libc-musl = "\
+ gt_cv_func_gnugettext1_libc=yes \
+ gt_cv_func_gnugettext2_libc=yes \
+ "
+
do_configure_prepend() {
if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then
cat > ${WORKDIR}/python << EOF