aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-support/nss/nss_3.36.1.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-support/nss/nss_3.36.1.bb b/meta/recipes-support/nss/nss_3.36.1.bb
index f8555389ff..780a7ab088 100644
--- a/meta/recipes-support/nss/nss_3.36.1.bb
+++ b/meta/recipes-support/nss/nss_3.36.1.bb
@@ -89,6 +89,8 @@ do_compile() {
OS_TEST=ppc64
elif [ "${TARGET_ARCH}" = "mips" -o "${TARGET_ARCH}" = "mipsel" -o "${TARGET_ARCH}" = "mips64" -o "${TARGET_ARCH}" = "mips64el" ]; then
OS_TEST=mips
+ elif [ "${TARGET_ARCH}" = "aarch64_be" ]; then
+ OS_TEST="aarch64"
else
OS_TEST="${TARGET_ARCH}"
fi
@@ -144,6 +146,9 @@ do_install() {
OS_TEST=ppc64
elif [ "${TARGET_ARCH}" = "mips" -o "${TARGET_ARCH}" = "mipsel" -o "${TARGET_ARCH}" = "mips64" -o "${TARGET_ARCH}" = "mips64el" ]; then
OS_TEST=mips
+ elif [ "${TARGET_ARCH}" = "aarch64_be" ]; then
+ CPU_ARCH=aarch64
+ OS_TEST="aarch64"
else
OS_TEST="${TARGET_ARCH}"
fi