aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-extended/cups/cups-1.4.6/cups_serverbin.patch32
-rw-r--r--meta/recipes-extended/cups/cups14.inc26
-rw-r--r--meta/recipes-extended/cups/cups_1.4.6.bb7
3 files changed, 49 insertions, 16 deletions
diff --git a/meta/recipes-extended/cups/cups-1.4.6/cups_serverbin.patch b/meta/recipes-extended/cups/cups-1.4.6/cups_serverbin.patch
new file mode 100644
index 0000000000..f7b44a7bc1
--- /dev/null
+++ b/meta/recipes-extended/cups/cups-1.4.6/cups_serverbin.patch
@@ -0,0 +1,32 @@
+Make CUPS_SERVERBIN relative to libdir otherwise on 64bit arches
+e.g. ppc64 where base libdir is lib64 this does not go well
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Inappropriate [OE config specific]
+
+Index: cups-1.4.6/config-scripts/cups-directories.m4
+===================================================================
+--- cups-1.4.6.orig/config-scripts/cups-directories.m4 2009-04-12 16:04:51.000000000 -0700
++++ cups-1.4.6/config-scripts/cups-directories.m4 2012-07-21 12:12:05.896405923 -0700
+@@ -397,7 +397,7 @@
+ *)
+ # All others
+ INSTALL_SYSV="install-sysv"
+- CUPS_SERVERBIN="$exec_prefix/lib/cups"
++ CUPS_SERVERBIN="$libdir/cups"
+ ;;
+ esac
+
+Index: cups-1.4.6/configure
+===================================================================
+--- cups-1.4.6.orig/configure 2012-07-21 12:13:34.512405950 -0700
++++ cups-1.4.6/configure 2012-07-21 12:14:05.724406017 -0700
+@@ -11181,7 +11181,7 @@
+ *)
+ # All others
+ INSTALL_SYSV="install-sysv"
+- CUPS_SERVERBIN="$exec_prefix/lib/cups"
++ CUPS_SERVERBIN="$libdir/cups"
+ ;;
+ esac
+
diff --git a/meta/recipes-extended/cups/cups14.inc b/meta/recipes-extended/cups/cups14.inc
index 4f2b0a1dc4..0517007acd 100644
--- a/meta/recipes-extended/cups/cups14.inc
+++ b/meta/recipes-extended/cups/cups14.inc
@@ -27,7 +27,7 @@ EXTRA_OECONF = " \
do_configure() {
gnu-configize
libtoolize --force
- DSOFLAGS="${LDFLAGS}" oe_runconf
+ DSOFLAGS="${LDFLAGS}" SERVERBIN="${libdir}/cups" oe_runconf
}
do_compile () {
@@ -66,24 +66,24 @@ python do_package_append() {
PACKAGES =+ "${PN}-lib ${PN}-libimage"
-FILES_${PN} += "${exec_prefix}/lib/cups/backend \
- ${exec_prefix}/lib/cups/cgi-bin \
- ${exec_prefix}/lib/cups/filter \
- ${exec_prefix}/lib/cups/monitor \
- ${exec_prefix}/lib/cups/notifier \
- ${exec_prefix}/lib/cups/daemon \
+FILES_${PN} += "${libdir}/cups/backend \
+ ${libdir}/cups/cgi-bin \
+ ${libdir}/cups/filter \
+ ${libdir}/cups/monitor \
+ ${libdir}/cups/notifier \
+ ${libdir}/cups/daemon \
"
FILES_${PN}-lib = "${libdir}/libcups.so.*"
FILES_${PN}-libimage = "${libdir}/libcupsimage.so.*"
-FILES_${PN}-dbg += "${exec_prefix}/lib/cups/backend/.debug \
- ${exec_prefix}/lib/cups/cgi-bin/.debug \
- ${exec_prefix}/lib/cups/filter/.debug \
- ${exec_prefix}/lib/cups/monitor/.debug \
- ${exec_prefix}/lib/cups/notifier/.debug \
- ${exec_prefix}/lib/cups/daemon/.debug \
+FILES_${PN}-dbg += "${libdir}/cups/backend/.debug \
+ ${libdir}/cups/cgi-bin/.debug \
+ ${libdir}/cups/filter/.debug \
+ ${libdir}/cups/monitor/.debug \
+ ${libdir}/cups/notifier/.debug \
+ ${libdir}/cups/daemon/.debug \
"
#package the html for the webgui inside the main packages (~1MB uncompressed)
diff --git a/meta/recipes-extended/cups/cups_1.4.6.bb b/meta/recipes-extended/cups/cups_1.4.6.bb
index 98251380da..84851804af 100644
--- a/meta/recipes-extended/cups/cups_1.4.6.bb
+++ b/meta/recipes-extended/cups/cups_1.4.6.bb
@@ -1,13 +1,14 @@
require cups14.inc
-PR = "r4"
+PR = "r5"
DEPENDS += "libusb \
${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=956e7600195e6139f12de8c2a5bbefa9"
SRC_URI += " \
- file://use_echo_only_in_init.patch \
- file://0001-don-t-try-to-run-generated-binaries.patch \
+ file://use_echo_only_in_init.patch \
+ file://0001-don-t-try-to-run-generated-binaries.patch \
+ file://cups_serverbin.patch \
"
SRC_URI[md5sum] = "de8fb5a29c36554925c0c6a6e2c0dae1"