summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-extended/lighttpd/lighttpd/fix-missing-test.patch23
-rw-r--r--meta/recipes-extended/lighttpd/lighttpd_1.4.68.bb (renamed from meta/recipes-extended/lighttpd/lighttpd_1.4.67.bb)23
2 files changed, 35 insertions, 11 deletions
diff --git a/meta/recipes-extended/lighttpd/lighttpd/fix-missing-test.patch b/meta/recipes-extended/lighttpd/lighttpd/fix-missing-test.patch
new file mode 100644
index 0000000000..6aa843b75d
--- /dev/null
+++ b/meta/recipes-extended/lighttpd/lighttpd/fix-missing-test.patch
@@ -0,0 +1,23 @@
+From d809433d6d900e899f796606b11bdc6a73413ac5 Mon Sep 17 00:00:00 2001
+From: Glenn Strauss <gstrauss@gluelogic.com>
+Date: Tue, 3 Jan 2023 17:50:16 -0500
+Subject: [PATCH] [meson] remove t/test_mod_evasive.c
+
+Upstream-Status: Backport [https://github.com/lighttpd/lighttpd1.4/commit/d809433d6d900e899f796606b11bdc6a73413ac5]
+Signed-off-by: Alexander Kanavin <alex@linutronix.de>
+---
+ src/meson.build | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/meson.build b/src/meson.build
+index ff472c320..77089fc3c 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -721,7 +721,6 @@ test('test_mod', executable('test_mod',
+ 't/test_mod.c',
+ 't/test_mod_access.c',
+ 't/test_mod_alias.c',
+- 't/test_mod_evasive.c',
+ 't/test_mod_evhost.c',
+ 't/test_mod_indexfile.c',
+ 't/test_mod_simple_vhost.c',
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.67.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.68.bb
index 838881f238..a9163f8492 100644
--- a/meta/recipes-extended/lighttpd/lighttpd_1.4.67.bb
+++ b/meta/recipes-extended/lighttpd/lighttpd_1.4.68.bb
@@ -17,9 +17,10 @@ SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.t
file://index.html.lighttpd \
file://lighttpd.conf \
file://lighttpd \
+ file://fix-missing-test.patch \
"
-SRC_URI[sha256sum] = "7e04d767f51a8d824b32e2483ef2950982920d427d1272ef4667f49d6f89f358"
+SRC_URI[sha256sum] = "e56f37ae52b63e1ada4d76ce78005affb6e56eea2f6bdb0ce17d6d36e9583384"
DEPENDS = "virtual/crypt"
@@ -27,19 +28,19 @@ PACKAGECONFIG ??= "openssl pcre zlib \
${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
"
-PACKAGECONFIG[libev] = "-Dwith_libev=true,-Dwith_libev=false,libev"
-PACKAGECONFIG[mysql] = "-Dwith_mysql=true,-Dwith_mysql=false,mariadb"
-PACKAGECONFIG[ldap] = "-Dwith_ldap=true,-Dwith_ldap=false,openldap"
+PACKAGECONFIG[libev] = "-Dwith_libev=enabled,-Dwith_libev=disabled,libev"
+PACKAGECONFIG[mysql] = "-Dwith_mysql=enabled,-Dwith_mysql=disabled,mariadb"
+PACKAGECONFIG[ldap] = "-Dwith_ldap=enabled,-Dwith_ldap=disabled,openldap"
PACKAGECONFIG[attr] = "-Dwith_xattr=true,-Dwith_xattr=false,attr"
PACKAGECONFIG[openssl] = "-Dwith_openssl=true,-Dwith_openssl=false,openssl"
-PACKAGECONFIG[krb5] = "-Dwith_krb5=true,-Dwith_krb5=false,krb5"
-PACKAGECONFIG[pcre] = "-Dwith_pcre=true,-Dwith_pcre=false,libpcre"
-PACKAGECONFIG[zlib] = "-Dwith_zlib=true,-Dwith_zlib=false,zlib"
-PACKAGECONFIG[bzip2] = "-Dwith_bzip=true,-Dwith_bzip=false,bzip2"
-PACKAGECONFIG[webdav-props] = "-Dwith_webdav_props=true,-Dwith_webdav_props=false,libxml2 sqlite3"
-PACKAGECONFIG[webdav-locks] = "-Dwith_webdav_locks=true,-Dwith_webdav_locks=false,util-linux"
+PACKAGECONFIG[krb5] = "-Dwith_krb5=enabled,-Dwith_krb5=disabled,krb5"
+PACKAGECONFIG[pcre] = "-Dwith_pcre=pcre2,-Dwith_pcre=disabled,libpcre2"
+PACKAGECONFIG[zlib] = "-Dwith_zlib=enabled,-Dwith_zlib=disabled,zlib"
+PACKAGECONFIG[bzip2] = "-Dwith_bzip=enabled,-Dwith_bzip=disabled,bzip2"
+PACKAGECONFIG[webdav-props] = "-Dwith_webdav_props=enabled,-Dwith_webdav_props=disabled,libxml2 sqlite3"
+PACKAGECONFIG[webdav-locks] = "-Dwith_webdav_locks=enabled,-Dwith_webdav_locks=disabled,util-linux"
PACKAGECONFIG[lua] = "-Dwith_lua=true,-Dwith_lua=false,lua"
-PACKAGECONFIG[zstd] = "-Dwith_zstd=true,-Dwith_zstd=false,zstd"
+PACKAGECONFIG[zstd] = "-Dwith_zstd=enabled,-Dwith_zstd=disabled,zstd"
inherit meson pkgconfig update-rc.d gettext systemd