summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--build/conf/bblayers.conf.sample5
-rw-r--r--build/conf/local.conf.sample10
-rw-r--r--meta-moblin/conf/layer.conf9
-rw-r--r--meta/conf/layer.conf11
-rwxr-xr-xscripts/poky-env-internal8
5 files changed, 32 insertions, 11 deletions
diff --git a/build/conf/bblayers.conf.sample b/build/conf/bblayers.conf.sample
new file mode 100644
index 0000000000..3ea6eda66a
--- /dev/null
+++ b/build/conf/bblayers.conf.sample
@@ -0,0 +1,5 @@
+BBFILES ?= ""
+BBLAYERS = " \
+ ${OEROOT}/meta \
+ ${OEROOT}/meta-moblin \
+ "
diff --git a/build/conf/local.conf.sample b/build/conf/local.conf.sample
index e195b33b88..959a3b9a3e 100644
--- a/build/conf/local.conf.sample
+++ b/build/conf/local.conf.sample
@@ -2,16 +2,6 @@
DL_DIR ?= "${OEROOT}/sources"
# Where to cache Poky's built staging output
PSTAGE_DIR ?= "${OEROOT}/pstage"
-BBFILES += "\
- ${OEROOT}/meta/packages/*/*.bb \
- ${OEROOT}/meta-moblin/packages/*/*.bb"
-
-BBFILE_COLLECTIONS = "normal moblin"
-BBFILE_PATTERN_normal = "^${OEROOT}/meta/"
-BBFILE_PATTERN_moblin = "^${OEROOT}/meta-moblin/"
-
-BBFILE_PRIORITY_normal = "5"
-BBFILE_PRIORITY_moblin = "5"
# Uncomment and set to allow bitbake to execute multiple tasks at once.
# For a quadcore, BB_NUMBER_THREADS = "4", PARALLEL_MAKE = "-j 4" would
diff --git a/meta-moblin/conf/layer.conf b/meta-moblin/conf/layer.conf
new file mode 100644
index 0000000000..ce5b0ac5e8
--- /dev/null
+++ b/meta-moblin/conf/layer.conf
@@ -0,0 +1,9 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH := "${BBPATH}${LAYERDIR}"
+
+# We have a packages directory, add to BBFILES
+BBFILES := "${BBFILES} ${LAYERDIR}/packages/*/*.bb"
+
+BBFILE_COLLECTIONS += "moblin"
+BBFILE_PATTERN_moblin := "^${OEROOT}/meta-moblin/"
+BBFILE_PRIORITY_moblin = "5"
diff --git a/meta/conf/layer.conf b/meta/conf/layer.conf
new file mode 100644
index 0000000000..567964f1ef
--- /dev/null
+++ b/meta/conf/layer.conf
@@ -0,0 +1,11 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH := "${BBPATH}${LAYERDIR}"
+
+# We have a packages directory, add to BBFILES
+BBFILES := "${BBFILES} ${LAYERDIR}/packages/*/*.bb"
+
+BBFILE_COLLECTIONS += "normal""
+BBFILE_PATTERN_normal := "^${LAYERDIR}/meta/"
+BBFILE_PRIORITY_normal = "5"
+
+
diff --git a/scripts/poky-env-internal b/scripts/poky-env-internal
index 4bfcf63c59..b931e29323 100755
--- a/scripts/poky-env-internal
+++ b/scripts/poky-env-internal
@@ -93,11 +93,17 @@ fi
if [ "x" = "x$POKYLOCALCONF" ]; then
POKYLOCALCONF="$BUILDDIR/conf/local.conf.sample"
fi
-
if ! (test -r "$BUILDDIR/conf/local.conf"); then
cp -f $POKYLOCALCONF $BUILDDIR/conf/local.conf
fi
+if [ "x" = "x$POKYLAYERCONF" ]; then
+ POKYLAYERCONF="$BUILDDIR/conf/bblayers.conf.sample"
+fi
+if ! (test -r "$BUILDDIR/conf/bblayers.conf"); then
+ cp -f $POKYLAYERCONF $BUILDDIR/conf/bblayers.conf
+fi
+
export BBPATH OEROOT BUILD_SYS BUILDDIR
# Kill off the TERMINFO variable, as glibc will grab its contents in its 'make