aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-graphics/cogl/cogl-1.0.inc4
-rw-r--r--meta/recipes-graphics/cogl/cogl-1.0_1.14.0.bb7
-rw-r--r--meta/recipes-graphics/cogl/cogl-1.0_1.16.0.bb6
-rw-r--r--meta/recipes-graphics/cogl/files/cogl-fixed-thumb.patch30
-rw-r--r--meta/recipes-graphics/cogl/files/cogl_fixed_mul-constraint.patch22
5 files changed, 6 insertions, 63 deletions
diff --git a/meta/recipes-graphics/cogl/cogl-1.0.inc b/meta/recipes-graphics/cogl/cogl-1.0.inc
index 0c4e86da33..c1e124a932 100644
--- a/meta/recipes-graphics/cogl/cogl-1.0.inc
+++ b/meta/recipes-graphics/cogl/cogl-1.0.inc
@@ -2,10 +2,6 @@ DESCRIPTION = "a modern 3D graphics API with associated utility APIs"
HOMEPAGE = "http://wiki.clutter-project.org/wiki/Cogl"
LICENSE = "LGPLv2.1+"
-SRC_URI += "file://cogl_fixed_mul-constraint.patch \
- file://cogl-fixed-thumb.patch \
- "
-
inherit clutter
DEPENDS = "glib-2.0 gdk-pixbuf"
diff --git a/meta/recipes-graphics/cogl/cogl-1.0_1.14.0.bb b/meta/recipes-graphics/cogl/cogl-1.0_1.14.0.bb
deleted file mode 100644
index 0f40c595ac..0000000000
--- a/meta/recipes-graphics/cogl/cogl-1.0_1.14.0.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-
-require cogl-1.0.inc
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
-
-SRC_URI[archive.md5sum] = "7eabaf4241c0b87cc9e3b0fa23fd0315"
-SRC_URI[archive.sha256sum] = "276e8c9f5ff0fcd57c1eaf74cc245f41ad469a95a18ac831fac2d5960baa5ae8"
diff --git a/meta/recipes-graphics/cogl/cogl-1.0_1.16.0.bb b/meta/recipes-graphics/cogl/cogl-1.0_1.16.0.bb
new file mode 100644
index 0000000000..5e5c82b501
--- /dev/null
+++ b/meta/recipes-graphics/cogl/cogl-1.0_1.16.0.bb
@@ -0,0 +1,6 @@
+require cogl-1.0.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+SRC_URI[archive.md5sum] = "611a61bed04354cbfffa3dc27feb6d4f"
+SRC_URI[archive.sha256sum] = "75c2c4636a050fda7ee8722ce3d9c618b08799ed92bbb72b4fdff3e73b096094"
diff --git a/meta/recipes-graphics/cogl/files/cogl-fixed-thumb.patch b/meta/recipes-graphics/cogl/files/cogl-fixed-thumb.patch
deleted file mode 100644
index 1825e88f1d..0000000000
--- a/meta/recipes-graphics/cogl/files/cogl-fixed-thumb.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Upstream-Status: Backport
-
-There are two asm() statements in cogl-fixed.c that can't be assembled
-in Thumb mode. Add a patch to switch to the generic code in Thumb mode.
-
-Signed-off-by: Donn Seeley <donn.seeley@windriver.com>
----
- cogl/cogl-fixed.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
---- a/cogl/cogl-fixed.c
-+++ b/cogl/cogl-fixed.c
-@@ -626,7 +626,7 @@ cogl_fixed_sqrt (CoglFixed x)
- /*
- * Find the highest bit set
- */
--#if defined (__arm__) && !defined(__ARM_ARCH_4T__)
-+#if defined (__arm__) && !defined(__ARM_ARCH_4T__) && !defined(__thumb__)
- /* This actually requires at least arm v5, but gcc does not seem
- * to set the architecture defines correctly, and it is I think
- * very unlikely that anyone will want to use clutter on anything
-@@ -804,7 +804,7 @@ CoglFixed
- cogl_fixed_mul (CoglFixed a,
- CoglFixed b)
- {
--#ifdef __arm__
-+#if defined(__arm__) && !defined(__thumb__)
- /* This provides about 12% speedeup on the gcc -O2 optimised
- * C version
- *
diff --git a/meta/recipes-graphics/cogl/files/cogl_fixed_mul-constraint.patch b/meta/recipes-graphics/cogl/files/cogl_fixed_mul-constraint.patch
deleted file mode 100644
index 179533ae80..0000000000
--- a/meta/recipes-graphics/cogl/files/cogl_fixed_mul-constraint.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Upstream-Status: Backport
-
-Add register constraints to prevent asm statement complaints like:
-
- {standard input}:382: rdhi, rdlo and rm must all be different
-
-Signed-off-by: Donn Seeley <donn.seeley@windriver.com>
----
- cogl/cogl-fixed.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/cogl/cogl-fixed.c
-+++ b/cogl/cogl-fixed.c
-@@ -816,7 +816,7 @@ cogl_fixed_mul (CoglFixed a,
- __asm__ ("smull %0, %1, %2, %3 \n"
- "mov %0, %0, lsr %4 \n"
- "add %1, %0, %1, lsl %5 \n"
-- : "=r"(res_hi), "=r"(res_low) \
-+ : "=&r"(res_hi), "=&r"(res_low) \
- : "r"(a), "r"(b), "i"(COGL_FIXED_Q), "i"(32 - COGL_FIXED_Q));
-
- return (CoglFixed) res_low;