aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-core/glibc/cross-localedef-native_2.23.bb9
1 files changed, 4 insertions, 5 deletions
diff --git a/meta/recipes-core/glibc/cross-localedef-native_2.23.bb b/meta/recipes-core/glibc/cross-localedef-native_2.23.bb
index fa930fd480..a6795ed9b3 100644
--- a/meta/recipes-core/glibc/cross-localedef-native_2.23.bb
+++ b/meta/recipes-core/glibc/cross-localedef-native_2.23.bb
@@ -9,6 +9,10 @@ LIC_FILES_CHKSUM = "file://LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
+# Tell autotools that we're working in the localedef directory
+#
+AUTOTOOLS_SCRIPT_PATH = "${S}/localedef"
+
inherit native
inherit autotools
@@ -47,11 +51,6 @@ S = "${WORKDIR}/git"
EXTRA_OECONF = "--with-glibc=${S}"
CFLAGS += "-fgnu89-inline -std=gnu99 -DIS_IN\(x\)='0'"
-do_configure () {
- ${S}/localedef/configure ${EXTRA_OECONF}
-}
-
-
do_install() {
install -d ${D}${bindir}
install -m 0755 ${B}/localedef ${D}${bindir}/cross-localedef