aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore23
-rw-r--r--documentation/poky-ref-manual/Makefile12
-rw-r--r--documentation/poky-ref-manual/bsp-guide.xml2
-rw-r--r--documentation/poky-ref-manual/poky-ref-manual.png (renamed from documentation/poky-ref-manual/poky-handbook.png)bin17829 -> 17829 bytes
-rw-r--r--documentation/poky-ref-manual/poky-ref-manual.xml (renamed from documentation/poky-ref-manual/poky-handbook.xml)2
-rw-r--r--documentation/poky-ref-manual/style.css2
-rw-r--r--documentation/template/poky-ref-manual.png (renamed from documentation/template/poky-handbook.png)bin32145 -> 32145 bytes
7 files changed, 14 insertions, 27 deletions
diff --git a/.gitignore b/.gitignore
index 439a15b2cc..f2db960e15 100644
--- a/.gitignore
+++ b/.gitignore
@@ -18,22 +18,9 @@ poky-autobuilder*
*.orig
*.rej
*~
-handbook/poky-doc-tools/Makefile
-handbook/poky-doc-tools/Makefile.in
-handbook/poky-doc-tools/aclocal.m4
-handbook/poky-doc-tools/autom4te.cache/
-handbook/poky-doc-tools/common/Makefile
-handbook/poky-doc-tools/common/Makefile.in
-handbook/poky-doc-tools/common/fop-config.xml
-handbook/poky-doc-tools/config.log
-handbook/poky-doc-tools/config.status
-handbook/poky-doc-tools/configure
-handbook/poky-doc-tools/install-sh
-handbook/poky-doc-tools/missing
-handbook/poky-doc-tools/poky-docbook-to-pdf
-handbook/poky-handbook.html
-handbook/poky-handbook.pdf
-handbook/poky-handbook.tgz
-handbook/bsp-guide.html
-handbook/bsp-guide.pdf
+documentation/poky-ref-manual/poky-ref-manual.html
+documentation/poky-ref-manual/poky-ref-manual.pdf
+documentation/poky-ref-manual/poky-ref-manual.tgz
+documentation/poky-ref-manual/bsp-guide.html
+documentation/poky-ref-manual/bsp-guide.pdf
diff --git a/documentation/poky-ref-manual/Makefile b/documentation/poky-ref-manual/Makefile
index 5c5761c401..22913e1554 100644
--- a/documentation/poky-ref-manual/Makefile
+++ b/documentation/poky-ref-manual/Makefile
@@ -1,7 +1,7 @@
all: html pdf tarball
pdf:
- ../tools/poky-docbook-to-pdf poky-handbook.xml ../template
+ ../tools/poky-docbook-to-pdf poky-ref-manual.xml ../template
../tools/poky-docbook-to-pdf bsp-guide.xml ../template
XSLTOPTS = --stringparam html.stylesheet style.css \
@@ -19,20 +19,20 @@ XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
html:
# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
- xsltproc $(XSLTOPTS) -o poky-handbook.html $(XSL_XHTML_URI) poky-handbook.xml
+ xsltproc $(XSLTOPTS) -o poky-ref-manual.html $(XSL_XHTML_URI) poky-ref-manual.xml
xsltproc $(XSLTOPTS) -o bsp-guide.html $(XSL_XHTML_URI) bsp-guide.xml
tarball: html
- tar -cvzf poky-handbook.tgz poky-handbook.html style.css screenshots/ss-sato.png poky-beaver.png poky-handbook.png
+ tar -cvzf poky-ref-manual.tgz poky-ref-manual.html style.css screenshots/ss-sato.png poky-beaver.png poky-ref-manual.png
validate:
- xmllint --postvalid --xinclude --noout poky-handbook.xml
+ xmllint --postvalid --xinclude --noout poky-ref-manual.xml
-OUTPUTS = poky-handbook.tgz poky-handbook.html poky-handbook.pdf bsp-guide.pdf bsp-guide.hml
+OUTPUTS = poky-ref-manual.tgz poky-ref-manual.html poky-ref-manual.pdf bsp-guide.pdf bsp-guide.html
SOURCES = *.png *.xml *.css *.svg
publish:
scp -r $(OUTPUTS) $(SOURCES) o-hand.com:/srv/www/pokylinux.org/doc/
clean:
- rm $(OUTPUTS)
+ rm -f $(OUTPUTS)
diff --git a/documentation/poky-ref-manual/bsp-guide.xml b/documentation/poky-ref-manual/bsp-guide.xml
index a1752bf535..e65325f510 100644
--- a/documentation/poky-ref-manual/bsp-guide.xml
+++ b/documentation/poky-ref-manual/bsp-guide.xml
@@ -9,7 +9,7 @@
<mediaobject>
<imageobject>
- <imagedata fileref='poky-handbook.png'
+ <imagedata fileref='poky-ref-manual.png'
format='SVG'
align='center' scalefit='1' width='100%'/>
</imageobject>
diff --git a/documentation/poky-ref-manual/poky-handbook.png b/documentation/poky-ref-manual/poky-ref-manual.png
index 333442e0d6..333442e0d6 100644
--- a/documentation/poky-ref-manual/poky-handbook.png
+++ b/documentation/poky-ref-manual/poky-ref-manual.png
Binary files differ
diff --git a/documentation/poky-ref-manual/poky-handbook.xml b/documentation/poky-ref-manual/poky-ref-manual.xml
index 445217c786..fc7ed35e13 100644
--- a/documentation/poky-ref-manual/poky-handbook.xml
+++ b/documentation/poky-ref-manual/poky-ref-manual.xml
@@ -9,7 +9,7 @@
<mediaobject>
<imageobject>
- <imagedata fileref='poky-handbook.png'
+ <imagedata fileref='poky-ref-manual.png'
format='SVG'
align='center' scalefit='1' width='100%'/>
</imageobject>
diff --git a/documentation/poky-ref-manual/style.css b/documentation/poky-ref-manual/style.css
index c4d9df197c..b5019bbee6 100644
--- a/documentation/poky-ref-manual/style.css
+++ b/documentation/poky-ref-manual/style.css
@@ -782,7 +782,7 @@ div.sect2 .titlepage .title {
h1.title {
background-color: transparent;
- background-image: url("poky-handbook.png");
+ background-image: url("poky-ref-manual.png");
background-repeat: no-repeat;
height: 256px;
text-indent: -9000px;
diff --git a/documentation/template/poky-handbook.png b/documentation/template/poky-ref-manual.png
index 2085edb467..2085edb467 100644
--- a/documentation/template/poky-handbook.png
+++ b/documentation/template/poky-ref-manual.png
Binary files differ