aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-sato/web/web/owl-window-menu.patch4
-rw-r--r--meta/recipes-sato/web/web_svn.bb14
2 files changed, 14 insertions, 4 deletions
diff --git a/meta/recipes-sato/web/web/owl-window-menu.patch b/meta/recipes-sato/web/web/owl-window-menu.patch
index 6e60dd0893..b80905fce3 100644
--- a/meta/recipes-sato/web/web/owl-window-menu.patch
+++ b/meta/recipes-sato/web/web/owl-window-menu.patch
@@ -1,7 +1,7 @@
Index: trunk/src/web_main.c
===================================================================
---- trunk.orig/src/web_main.c 2007-04-19 15:41:44.000000000 +0100
-+++ trunk/src/web_main.c 2007-04-26 07:43:23.000000000 +0100
+--- trunk.orig/src/web_main.c 2007-12-18 15:04:13.000000000 -0800
++++ trunk/src/web_main.c 2010-11-15 11:40:44.762994000 -0800
@@ -20,6 +20,8 @@
#include "web_bookmarks.h"
#include "web_request.h"
diff --git a/meta/recipes-sato/web/web_svn.bb b/meta/recipes-sato/web/web_svn.bb
index 583be4aa24..08005dd253 100644
--- a/meta/recipes-sato/web/web_svn.bb
+++ b/meta/recipes-sato/web/web_svn.bb
@@ -1,4 +1,4 @@
-LICENSE = "GPL"
+LICENSE = "GPLv2"
SECTION = "x11"
DEPENDS = "libxml2 glib-2.0 gtk+ libglade gtkhtml2 curl gconf js libowl"
DESCRIPTION = "Web is a multi-platform web browsing application."
@@ -7,10 +7,20 @@ PR = "r2"
PV = "0.0+svnr${SRCREV}"
SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \
- file://owl-window-menu.patch;patch=1 \
+ file://owl-window-menu.patch \
"
+LIB_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
S = "${WORKDIR}/trunk"
+do_unpack_append () {
+ bb.build.exec_func('do_remove_patches', d)
+}
+
+do_remove_patches () {
+ rm -rf ${S}/patches
+}
+
inherit autotools pkgconfig gconf