aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools/0001-Makefile-build-mktables-using-native-gcc.patch30
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools_4.12.bb (renamed from meta/recipes-devtools/btrfs-tools/btrfs-tools_4.11.1.bb)6
2 files changed, 34 insertions, 2 deletions
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools/0001-Makefile-build-mktables-using-native-gcc.patch b/meta/recipes-devtools/btrfs-tools/btrfs-tools/0001-Makefile-build-mktables-using-native-gcc.patch
new file mode 100644
index 0000000000..a81900ee7e
--- /dev/null
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools/0001-Makefile-build-mktables-using-native-gcc.patch
@@ -0,0 +1,30 @@
+From e58369f6d36bc51eb59d6afa34c1cae3ff0810ef Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Mon, 7 Aug 2017 14:10:38 +0300
+Subject: [PATCH] Makefile: build mktables using native gcc
+
+It's a throwaway helper binary used during build, and so it needs to
+be native.
+
+Upstream-Status: Inappropriate [oe specific]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index b3e2b63..347aaf1 100644
+--- a/Makefile
++++ b/Makefile
+@@ -323,7 +323,7 @@ version.h: version.sh version.h.in configure.ac
+
+ mktables: kernel-lib/mktables.c
+ @echo " [CC] $@"
+- $(Q)$(CC) $(CFLAGS) $< -o $@
++ $(Q)$(BUILD_CC) $(BUILD_CFLAGS) $< -o $@
+
+ kernel-lib/tables.c: mktables
+ @echo " [TABLE] $@"
+--
+2.13.2
+
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.11.1.bb b/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.12.bb
index a7b42e9546..c3cc89c2b0 100644
--- a/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.11.1.bb
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.12.bb
@@ -14,8 +14,10 @@ DEPENDS = "util-linux attr e2fsprogs lzo acl"
DEPENDS_append_class-target = " udev"
RDEPENDS_${PN} = "libgcc"
-SRCREV = "88221fc081a7a0979a012f243b66cf097382cc8f"
-SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git"
+SRCREV = "0607132c3200bcead1426e6dc685432008de95de"
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
+ file://0001-Makefile-build-mktables-using-native-gcc.patch \
+ "
inherit autotools-brokensep pkgconfig manpages