aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-extended/net-tools/net-tools_1.60-26.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta/recipes-extended/net-tools/net-tools_1.60-26.bb b/meta/recipes-extended/net-tools/net-tools_1.60-26.bb
index be267351e3..115b3987c3 100644
--- a/meta/recipes-extended/net-tools/net-tools_1.60-26.bb
+++ b/meta/recipes-extended/net-tools/net-tools_1.60-26.bb
@@ -70,11 +70,21 @@ python do_patch() {
bb.build.exec_func('patch_do_patch', d)
}
+# i18n only enabled for the target, doesn't build for native
+# and isn't needed there.
+disable_i18n() {
+ sed -i -e 's/^I18N=1/# I18N=1/' ${S}/config.make
+}
+disable_i18n_class-target () {
+ :
+}
+
do_configure() {
# net-tools has its own config mechanism requiring "make config"
# we pre-generate desired options and copy to source directory instead
cp ${WORKDIR}/net-tools-config.h ${S}/config.h
cp ${WORKDIR}/net-tools-config.make ${S}/config.make
+ disable_i18n
}
do_compile() {
@@ -125,3 +135,4 @@ python __anonymous() {
}
ALTERNATIVE_PRIORITY = "100"
+BBCLASSEXTEND = "native nativesdk"