aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-graphics/mesa/mesa-demos/0012-Fix-gles-configurability.patch39
-rw-r--r--meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb1
2 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-demos/0012-Fix-gles-configurability.patch b/meta/recipes-graphics/mesa/mesa-demos/0012-Fix-gles-configurability.patch
new file mode 100644
index 0000000000..0b437a47d0
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa-demos/0012-Fix-gles-configurability.patch
@@ -0,0 +1,39 @@
+Index: mesa-demos-8.2.0/src/egl/opengles1/Makefile.am
+===================================================================
+--- mesa-demos-8.2.0.orig/src/egl/opengles1/Makefile.am 2016-07-29 10:52:50.131729547 -0500
++++ mesa-demos-8.2.0/src/egl/opengles1/Makefile.am 2016-07-29 10:59:26.000000000 -0500
+@@ -36,6 +36,8 @@
+ $(EGL_LIBS) \
+ -lm
+
++if HAVE_EGL
++if HAVE_GLESV1
+ bin_PROGRAMS =
+
+ if HAVE_X11
+@@ -76,3 +78,5 @@
+ torus_x11_LDADD = ../eglut/libeglut_x11.la
+ tri_x11_LDADD = ../eglut/libeglut_x11.la
+ endif
++endif
++endif
+Index: mesa-demos-8.2.0/src/egl/opengles2/Makefile.am
+===================================================================
+--- mesa-demos-8.2.0.orig/src/egl/opengles2/Makefile.am 2016-07-29 10:52:50.131729547 -0500
++++ mesa-demos-8.2.0/src/egl/opengles2/Makefile.am 2016-07-29 10:59:03.000000000 -0500
+@@ -33,6 +33,8 @@
+ $(EGL_LIBS) \
+ -lm
+
++if HAVE_EGL
++if HAVE_GLESV2
+ bin_PROGRAMS =
+
+ if HAVE_WAYLAND
+@@ -53,4 +55,5 @@
+ es2gears_x11_LDADD = ../eglut/libeglut_x11.la
+ es2tri_LDADD = $(X11_LIBS)
+ endif
+-
++endif
++endif
diff --git a/meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb b/meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb
index 2df9bbac29..8e12d82e11 100644
--- a/meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb
+++ b/meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb
@@ -21,6 +21,7 @@ SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/demos/${PV}/${BPN}-${PV}.tar.bz2 \
file://0009-glsl-perf-Install-.glsl-.vert-.frag-files.patch \
file://0010-sharedtex_mt-fix-rendering-thread-hang.patch \
file://0011-drop-demos-dependant-on-obsolete-MESA_screen_surface.patch \
+ file://0012-Fix-gles-configurability.patch \
"
SRC_URI[md5sum] = "72613a2c8c013716db02e3ff59d29061"
SRC_URI[sha256sum] = "e4bfecb5816ddd4b7b37c1bc876b63f1f7f06fda5879221a9774d0952f90ba92"