aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-bsp/qemu-config/qemu-config.bb6
-rw-r--r--meta/recipes-devtools/devel-config/anjuta-remote-run.bb19
-rw-r--r--meta/recipes-devtools/devel-config/anjuta-remote-run/anjuta-remote-run (renamed from meta/recipes-bsp/qemu-config/qemu-config/anjuta-remote-run)0
3 files changed, 20 insertions, 5 deletions
diff --git a/meta/recipes-bsp/qemu-config/qemu-config.bb b/meta/recipes-bsp/qemu-config/qemu-config.bb
index ac3e7f3dad..6775af34e3 100644
--- a/meta/recipes-bsp/qemu-config/qemu-config.bb
+++ b/meta/recipes-bsp/qemu-config/qemu-config.bb
@@ -10,7 +10,6 @@ COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemumips|qemuppc)"
PR = "r25"
SRC_URI = "file://distcc.sh \
- file://anjuta-remote-run \
file://exports \
file://shutdown.desktop \
file://qemu-autostart"
@@ -23,9 +22,6 @@ do_install() {
install -m 0755 distcc.sh ${D}${sysconfdir}/profile.d/
install -m 0644 exports ${D}${sysconfdir}/
- install -d ${D}${bindir}
- install -m 0755 anjuta-remote-run ${D}${bindir}/
-
install -d ${D}${datadir}/applications
install -m 0644 shutdown.desktop ${D}${datadir}/applications/
@@ -38,7 +34,7 @@ pkg_postinst_${PN} () {
sed -i $D${datadir}/applications/shutdown.desktop -e 's/^Exec=halt/Exec=reboot/'
}
-RDEPENDS_${PN} = "distcc ${@base_contains('DISTRO_FEATURES', 'x11', 'dbus-x11', '', d)} packagegroup-core-nfs-server oprofileui-server rsync bash"
+RDEPENDS_${PN} = "distcc packagegroup-core-nfs-server oprofileui-server bash"
inherit update-rc.d allarch
diff --git a/meta/recipes-devtools/devel-config/anjuta-remote-run.bb b/meta/recipes-devtools/devel-config/anjuta-remote-run.bb
new file mode 100644
index 0000000000..51fdf9ecac
--- /dev/null
+++ b/meta/recipes-devtools/devel-config/anjuta-remote-run.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Provides on-device script for interaction with the Anjuta IDE"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "file://anjuta-remote-run"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 anjuta-remote-run ${D}${bindir}/
+}
+
+PACKAGES = "${PN}"
+RDEPENDS_${PN} = "dbus rsync"
+
+inherit allarch
+
diff --git a/meta/recipes-bsp/qemu-config/qemu-config/anjuta-remote-run b/meta/recipes-devtools/devel-config/anjuta-remote-run/anjuta-remote-run
index 620e3a705b..620e3a705b 100644
--- a/meta/recipes-bsp/qemu-config/qemu-config/anjuta-remote-run
+++ b/meta/recipes-devtools/devel-config/anjuta-remote-run/anjuta-remote-run