aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--documentation/dev-manual/dev-manual-common-tasks.xml4
-rw-r--r--documentation/ref-manual/ref-classes.xml58
-rw-r--r--documentation/ref-manual/ref-variables.xml8
3 files changed, 6 insertions, 64 deletions
diff --git a/documentation/dev-manual/dev-manual-common-tasks.xml b/documentation/dev-manual/dev-manual-common-tasks.xml
index 927dcf021b..e97cc734f9 100644
--- a/documentation/dev-manual/dev-manual-common-tasks.xml
+++ b/documentation/dev-manual/dev-manual-common-tasks.xml
@@ -3843,8 +3843,8 @@
standalone utility that initially provides
easier-to-use and more flexible replacements for a
couple bits of existing functionality in OE Core's
- <filename>boot-directdisk.bbclass</filename> and
- <filename>mkefidisk.sh</filename> scripts.
+ <ulink url='&YOCTO_DOCS_REF_URL;#ref-classes-image-live'><filename>image-live</filename></ulink>
+ class and <filename>mkefidisk.sh</filename> script.
The difference between
<filename>wic</filename> and those examples is
that with <filename>wic</filename> the
diff --git a/documentation/ref-manual/ref-classes.xml b/documentation/ref-manual/ref-classes.xml
index 1351991985..ccab5e68ab 100644
--- a/documentation/ref-manual/ref-classes.xml
+++ b/documentation/ref-manual/ref-classes.xml
@@ -319,64 +319,6 @@
</para>
</section>
-<section id='ref-classes-boot-directdisk'>
- <title><filename>boot-directdisk.bbclass</filename></title>
-
- <para>
- The <filename>boot-directdisk</filename> class
- creates an image that can be placed directly onto a hard disk using
- <filename>dd</filename> and then booted.
- The image uses SYSLINUX.
- </para>
-
- <para>
- The end result is a 512 boot sector populated with a
- Master Boot Record (MBR) and partition table followed by an MSDOS
- FAT16 partition containing SYSLINUX and a Linux kernel completed by
- the <filename>ext2</filename> and <filename>ext3</filename>
- root filesystems.
- </para>
-</section>
-
-<section id='ref-classes-bootimg'>
- <title><filename>bootimg.bbclass</filename></title>
-
- <para>
- The <filename>bootimg</filename> class creates a bootable
- image using SYSLINUX, your kernel, and an optional initial RAM disk
- (<filename>initrd</filename>).
- </para>
-
- <para>
- When you use this class, two things happen:
- <itemizedlist>
- <listitem><para>
- A <filename>.hddimg</filename> file is created.
- This file is an MSDOS filesystem that contains SYSLINUX,
- a kernel, an <filename>initrd</filename>, and a root filesystem
- image.
- All three of these can be written to hard drives directly and
- also booted on a USB flash disks using <filename>dd</filename>.
- </para></listitem>
- <listitem><para>
- A CD <filename>.iso</filename> image is created.
- When this file is booted, the <filename>initrd</filename>
- boots and processes the label selected in SYSLINUX.
- Actions based on the label are then performed (e.g. installing
- to a hard drive).</para></listitem>
- </itemizedlist>
- </para>
-
- <para>
- The <filename>bootimg</filename> class supports the
- <link linkend='var-INITRD'><filename>INITRD</filename></link>,
- <link linkend='var-NOISO'><filename>NOISO</filename></link>,
- <link linkend='var-NOHDD'><filename>NOHDD</filename></link>, and
- <link linkend='var-ROOTFS'><filename>ROOTFS</filename></link>
- variables.
- </para>
-</section>
-
<section id='ref-classes-bugzilla'>
<title><filename>bugzilla.bbclass</filename></title>
diff --git a/documentation/ref-manual/ref-variables.xml b/documentation/ref-manual/ref-variables.xml
index 244f68a3f7..d66fe1b0c6 100644
--- a/documentation/ref-manual/ref-variables.xml
+++ b/documentation/ref-manual/ref-variables.xml
@@ -6109,7 +6109,7 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
<para>
The <filename>INITRD</filename> variable is an optional
variable used with the
- <link linkend='ref-classes-bootimg'><filename>bootimg</filename></link>
+ <link linkend='ref-classes-image-live'><filename>image-live</filename></link>
class.
</para>
</glossdef>
@@ -8073,7 +8073,7 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
Causes the OpenEmbedded build system to skip building the
<filename>.hddimg</filename> image.
The <filename>NOHDD</filename> variable is used with the
- <link linkend='ref-classes-bootimg'><filename>bootimg</filename></link>
+ <link linkend='ref-classes-image-live'><filename>image-live</filename></link>
class.
Set the variable to "1" to prevent the
<filename>.hddimg</filename> image from being built.
@@ -8091,7 +8091,7 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
Causes the OpenEmbedded build system to skip building the
ISO image.
The <filename>NOISO</filename> variable is used with the
- <link linkend='ref-classes-bootimg'><filename>bootimg</filename></link>
+ <link linkend='ref-classes-image-live'><filename>image-live</filename></link>
class.
Set the variable to "1" to prevent the ISO image from
being built.
@@ -10212,7 +10212,7 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
<para>
The <filename>ROOTFS</filename> variable is an optional
variable used with the
- <link linkend='ref-classes-bootimg'><filename>bootimg</filename></link>
+ <link linkend='ref-classes-image-live'><filename>image-live</filename></link>
class.
</para>
</glossdef>