aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--documentation/kernel-dev/kernel-dev-advanced.xml28
-rw-r--r--documentation/ref-manual/ref-variables.xml5
2 files changed, 19 insertions, 14 deletions
diff --git a/documentation/kernel-dev/kernel-dev-advanced.xml b/documentation/kernel-dev/kernel-dev-advanced.xml
index 785076026d..9b35a422db 100644
--- a/documentation/kernel-dev/kernel-dev-advanced.xml
+++ b/documentation/kernel-dev/kernel-dev-advanced.xml
@@ -24,9 +24,9 @@
<title>Using Kernel Metadata in a Recipe</title>
<para>
- The kernel sources in the Yocto Project contain kernel Metadata, which is
- located in the <filename>meta</filename> branches of the kernel source
- Git repositories.
+ The kernel sources in the Yocto Project contain kernel Metadata, which
+ is located in the <filename>meta</filename> branches of the kernel
+ source Git repositories.
This Metadata defines Board Support Packages (BSPs) that
correspond to definitions in linux-yocto recipes for the same BSPs.
A BSP consists of an aggregation of kernel policy and hardware-specific
@@ -61,20 +61,26 @@
</para>
<para>
+ Every linux-yocto style recipe must also indicate the Linux kernel
+ source repository branch used to build the Linux kernel.
+ The <ulink url='&YOCTO_DOCS_REF_URL;#var-KBRANCH'>KBRANCH</ulink>
+ variable must be set to indicate the branch.
+ <note>
+ You can use the <filename>KBRANCH</filename> value to define an
+ alternate branch typically with a machine override as follows:
+ <literallayout class='monospaced'>
+ KBRANCH_fri2 ?= "standard/fri2"
+ </literallayout>
+ </note>
+ </para>
+
+ <para>
The linux-yocto style recipes can optionally define the following
variables:
<literallayout class='monospaced'>
- <ulink url='&YOCTO_DOCS_REF_URL;#var-KBRANCH'>KBRANCH</ulink>
<ulink url='&YOCTO_DOCS_REF_URL;#var-KERNEL_FEATURES'>KERNEL_FEATURES</ulink>
<ulink url='&YOCTO_DOCS_REF_URL;#var-LINUX_KERNEL_TYPE'>LINUX_KERNEL_TYPE</ulink>
</literallayout>
- <filename>KBRANCH</filename> defines the Linux kernel source
- repository's branch to use to build the Linux kernel.
- You can use the value to define an alternate branch typically with a
- machine override as follows:
- <literallayout class='monospaced'>
- KBRANCH_fri2 ?= "standard/fri2"
- </literallayout>
</para>
<para>
diff --git a/documentation/ref-manual/ref-variables.xml b/documentation/ref-manual/ref-variables.xml
index 6bcbbb316f..98799d5c95 100644
--- a/documentation/ref-manual/ref-variables.xml
+++ b/documentation/ref-manual/ref-variables.xml
@@ -5758,10 +5758,9 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
<glossdef>
<para role="glossdeffirst"><imagedata fileref="figures/define-generic.png" />
A regular expression used by the build process to explicitly
- identify the kernel branch that is validated, patched
+ identify the kernel branch that is validated, patched,
and configured during a build.
- The <filename>KBRANCH</filename> variable is optional.
- You can use it to trigger checks to ensure the exact kernel
+ You must set this variable to ensure the exact kernel
branch you want is being used by the build process.
</para>