aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--documentation/Makefile26
-rw-r--r--documentation/dev-manual/dev-manual-kernel-appendix.xml24
-rw-r--r--documentation/dev-manual/figures/kernel-example-repos-danny.pngbin0 -> 25097 bytes
-rw-r--r--documentation/dev-manual/figures/kernel-example-repos-denzil.pngbin34344 -> 0 bytes
-rw-r--r--documentation/mega-manual/figures/kernel-example-repos-danny.pngbin0 -> 25097 bytes
-rw-r--r--documentation/mega-manual/figures/kernel-example-repos-denzil.pngbin34344 -> 0 bytes
6 files changed, 36 insertions, 14 deletions
diff --git a/documentation/Makefile b/documentation/Makefile
index ee7089aee6..33fcd7a511 100644
--- a/documentation/Makefile
+++ b/documentation/Makefile
@@ -115,11 +115,20 @@ TARFILES = dev-style.css dev-manual.html dev-manual.pdf \
figures/kernel-overview-3-denzil.png \
figures/source-repos.png figures/yp-download.png \
figures/wip.png
+ else ifeq ($(BRANCH),danny)
+TARFILES = dev-style.css dev-manual.html dev-manual.pdf \
+ figures/app-dev-flow.png figures/bsp-dev-flow.png figures/dev-title.png \
+ figures/git-workflow.png figures/index-downloads.png figures/kernel-dev-flow.png \
+ figures/kernel-example-repos-danny.png \
+ figures/kernel-overview-1.png figures/kernel-overview-2.png \
+ figures/kernel-overview-3-denzil.png \
+ figures/source-repos.png figures/yp-download.png \
+ figures/wip.png
else
TARFILES = dev-style.css dev-manual.html dev-manual.pdf \
figures/app-dev-flow.png figures/bsp-dev-flow.png figures/dev-title.png \
figures/git-workflow.png figures/index-downloads.png figures/kernel-dev-flow.png \
- figures/kernel-example-repos-denzil.png \
+ figures/kernel-example-repos-danny.png \
figures/kernel-overview-1.png figures/kernel-overview-2.png \
figures/kernel-overview-3-denzil.png \
figures/source-repos.png figures/yp-download.png \
@@ -176,6 +185,19 @@ TARFILES = mega-manual.html mega-style.css figures/yocto-environment.png figures
figures/kernel-overview-3-denzil.png \
figures/source-repos.png figures/yp-download.png \
figures/wip.png
+ else ifeq ($(BRANCH),danny)
+TARFILES = mega-manual.html mega-style.css figures/yocto-environment.png figures/building-an-image.png \
+ figures/using-a-pre-built-image.png \
+ figures/poky-title.png \
+ figures/adt-title.png figures/bsp-title.png \
+ figures/kernel-title.png figures/kernel-architecture-overview.png \
+ figures/app-dev-flow.png figures/bsp-dev-flow.png figures/dev-title.png \
+ figures/git-workflow.png figures/index-downloads.png figures/kernel-dev-flow.png \
+ figures/kernel-example-repos-danny.png \
+ figures/kernel-overview-1.png figures/kernel-overview-2.png \
+ figures/kernel-overview-3-denzil.png \
+ figures/source-repos.png figures/yp-download.png \
+ figures/wip.png
else
TARFILES = mega-manual.html mega-style.css figures/yocto-environment.png figures/building-an-image.png \
figures/using-a-pre-built-image.png \
@@ -184,7 +206,7 @@ TARFILES = mega-manual.html mega-style.css figures/yocto-environment.png figures
figures/kernel-title.png figures/kernel-architecture-overview.png \
figures/app-dev-flow.png figures/bsp-dev-flow.png figures/dev-title.png \
figures/git-workflow.png figures/index-downloads.png figures/kernel-dev-flow.png \
- figures/kernel-example-repos-denzil.png \
+ figures/kernel-example-repos-danny.png \
figures/kernel-overview-1.png figures/kernel-overview-2.png \
figures/kernel-overview-3-denzil.png \
figures/source-repos.png figures/yp-download.png \
diff --git a/documentation/dev-manual/dev-manual-kernel-appendix.xml b/documentation/dev-manual/dev-manual-kernel-appendix.xml
index 3a65df1d3b..62410c90f5 100644
--- a/documentation/dev-manual/dev-manual-kernel-appendix.xml
+++ b/documentation/dev-manual/dev-manual-kernel-appendix.xml
@@ -41,11 +41,11 @@
Briefly, you need the following:
<itemizedlist>
<listitem><para>A local
- <link linkend='source-directory'>source directory</link> for the
+ <link linkend='source-directory'>Source Directory</link> for the
poky Git repository</para></listitem>
<listitem><para>Local copies of the
<link linkend='poky-extras-repo'><filename>poky-extras</filename></link>
- Git repository placed within the source directory.</para></listitem>
+ Git repository placed within the Source Directory.</para></listitem>
<listitem><para>A bare clone of the
<link linkend='local-kernel-files'>Yocto Project Kernel</link> upstream Git
repository to which you want to push your modifications.
@@ -66,7 +66,7 @@
</para>
<para>
- <imagedata fileref="figures/kernel-example-repos-denzil.png" width="7in" depth="5in"
+ <imagedata fileref="figures/kernel-example-repos-danny.png" width="7in" depth="5in"
align="center" scale="100" />
</para>
@@ -76,10 +76,10 @@
<listitem><para><emphasis>Local Source Directory:</emphasis>
This area contains all the metadata that supports building images
using the OpenEmbedded build system.
- In this example, the source directory also
+ In this example, the Source Directory also
contains the build directory, which contains the configuration directory
that lets you control the build.
- Also in this example, the source directory contains local copies of the
+ Also in this example, the Source Directory contains local copies of the
<filename>poky-extras</filename> Git repository.</para>
<para>See the bulleted item
"<link linkend='local-yp-release'>Yocto Project Release</link>"
@@ -132,17 +132,17 @@
<title>Setting Up the Local Source Directory</title>
<para>
- You can set up the source directory through tarball extraction or by
+ You can set up the Source Directory through tarball extraction or by
cloning the <filename>poky</filename> Git repository.
This example uses <filename>poky</filename> as the root directory of the
- local source directory.
+ local Source Directory.
See the bulleted item
"<link linkend='local-yp-release'>Yocto Project Release</link>"
for information on how to get these files.
</para>
<para>
- Once you have source directory set up,
+ Once you have Source Directory set up,
you have many development branches from which you can work.
From inside the local repository you can see the branch names and the tag names used
in the upstream Git repository by using either of the following commands:
@@ -168,7 +168,7 @@
<para>
This example creates a local copy of the <filename>poky-extras</filename> Git
- repository inside the <filename>poky</filename> source directory.
+ repository inside the <filename>poky</filename> Source Directory.
See the bulleted item "<link linkend='poky-extras-repo'>The
<filename>poky-extras</filename> Git Repository</link>"
for information on how to set up a local copy of the
@@ -530,7 +530,7 @@
<para>
If you took the time to work through the example that modifies the kernel source code
in "<link linkend='modifying-the-kernel-source-code'>Modifying the Kernel Source
- Code</link>" you should already have the source directory set up on your
+ Code</link>" you should already have the Source Directory set up on your
host machine.
If this is the case, go to the next section, which is titled
"<link linkend='examining-the-default-config-smp-behavior'>Examining the Default
@@ -539,11 +539,11 @@
</para>
<para>
- If you don't have the source directory established on your system,
+ If you don't have the Source Directory established on your system,
you can get them through tarball extraction or by
cloning the <filename>poky</filename> Git repository.
This example uses <filename>poky</filename> as the root directory of the
- <link linkend='source-directory'>source directory</link>.
+ <link linkend='source-directory'>Source Directory</link>.
See the bulleted item
"<link linkend='local-yp-release'>Yocto Project Release</link>"
for information on how to get these files.
diff --git a/documentation/dev-manual/figures/kernel-example-repos-danny.png b/documentation/dev-manual/figures/kernel-example-repos-danny.png
new file mode 100644
index 0000000000..01cf47ccb8
--- /dev/null
+++ b/documentation/dev-manual/figures/kernel-example-repos-danny.png
Binary files differ
diff --git a/documentation/dev-manual/figures/kernel-example-repos-denzil.png b/documentation/dev-manual/figures/kernel-example-repos-denzil.png
deleted file mode 100644
index 79fc60698b..0000000000
--- a/documentation/dev-manual/figures/kernel-example-repos-denzil.png
+++ /dev/null
Binary files differ
diff --git a/documentation/mega-manual/figures/kernel-example-repos-danny.png b/documentation/mega-manual/figures/kernel-example-repos-danny.png
new file mode 100644
index 0000000000..01cf47ccb8
--- /dev/null
+++ b/documentation/mega-manual/figures/kernel-example-repos-danny.png
Binary files differ
diff --git a/documentation/mega-manual/figures/kernel-example-repos-denzil.png b/documentation/mega-manual/figures/kernel-example-repos-denzil.png
deleted file mode 100644
index 79fc60698b..0000000000
--- a/documentation/mega-manual/figures/kernel-example-repos-denzil.png
+++ /dev/null
Binary files differ