aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/lib/oeqa/runtime/buildgalculator.py1
-rw-r--r--meta/lib/oeqa/runtime/kernelmodule.py2
-rw-r--r--meta/lib/oeqa/runtime/logrotate.py3
-rw-r--r--meta/lib/oeqa/runtime/pam.py2
4 files changed, 5 insertions, 3 deletions
diff --git a/meta/lib/oeqa/runtime/buildgalculator.py b/meta/lib/oeqa/runtime/buildgalculator.py
index 28ba29e5c2..220101d55c 100644
--- a/meta/lib/oeqa/runtime/buildgalculator.py
+++ b/meta/lib/oeqa/runtime/buildgalculator.py
@@ -7,6 +7,7 @@ def setUpModule():
skipModule("Image doesn't have tools-sdk in IMAGE_FEATURES")
class GalculatorTest(oeRuntimeTest):
+ @testcase(1526)
@skipUnlessPassed("test_ssh")
def test_galculator(self):
try:
diff --git a/meta/lib/oeqa/runtime/kernelmodule.py b/meta/lib/oeqa/runtime/kernelmodule.py
index 38ca184540..2ac1bc93d4 100644
--- a/meta/lib/oeqa/runtime/kernelmodule.py
+++ b/meta/lib/oeqa/runtime/kernelmodule.py
@@ -14,7 +14,7 @@ class KernelModuleTest(oeRuntimeTest):
self.target.copy_to(os.path.join(oeRuntimeTest.tc.filesdir, "hellomod.c"), "/tmp/hellomod.c")
self.target.copy_to(os.path.join(oeRuntimeTest.tc.filesdir, "hellomod_makefile"), "/tmp/Makefile")
- @testcase('316')
+ @testcase('1541')
@skipUnlessPassed('test_ssh')
@skipUnlessPassed('test_gcc_compile')
def test_kernel_module(self):
diff --git a/meta/lib/oeqa/runtime/logrotate.py b/meta/lib/oeqa/runtime/logrotate.py
index de300bf55f..cf88c54dfa 100644
--- a/meta/lib/oeqa/runtime/logrotate.py
+++ b/meta/lib/oeqa/runtime/logrotate.py
@@ -12,6 +12,7 @@ def setUpModule():
class LogrotateTest(oeRuntimeTest):
+ @testcase(1544)
@skipUnlessPassed("test_ssh")
def test_1_logrotate_setup(self):
(status, output) = self.target.run('mkdir $HOME/logrotate_dir')
@@ -19,7 +20,7 @@ class LogrotateTest(oeRuntimeTest):
(status, output) = self.target.run("sed -i \"s#wtmp {#wtmp {\\n olddir $HOME/logrotate_dir#\" /etc/logrotate.conf")
self.assertEqual(status, 0, msg = "Could not write to logrotate.conf file. Status and output: %s and %s)" % (status, output))
- @testcase(289)
+ @testcase(1542)
@skipUnlessPassed("test_1_logrotate_setup")
def test_2_logrotate(self):
(status, output) = self.target.run('logrotate -f /etc/logrotate.conf')
diff --git a/meta/lib/oeqa/runtime/pam.py b/meta/lib/oeqa/runtime/pam.py
index c8205c9abc..b7f2dfa49b 100644
--- a/meta/lib/oeqa/runtime/pam.py
+++ b/meta/lib/oeqa/runtime/pam.py
@@ -12,7 +12,7 @@ def setUpModule():
class PamBasicTest(oeRuntimeTest):
- @testcase(287)
+ @testcase(1543)
@skipUnlessPassed('test_ssh')
def test_pam(self):
(status, output) = self.target.run('login --help')