aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-graphics/xorg-xserver/xserver-xorg/xshmfence-option.patch32
1 files changed, 17 insertions, 15 deletions
diff --git a/meta/recipes-graphics/xorg-xserver/xserver-xorg/xshmfence-option.patch b/meta/recipes-graphics/xorg-xserver/xserver-xorg/xshmfence-option.patch
index 55e09134ce..682ddf7006 100644
--- a/meta/recipes-graphics/xorg-xserver/xserver-xorg/xshmfence-option.patch
+++ b/meta/recipes-graphics/xorg-xserver/xserver-xorg/xshmfence-option.patch
@@ -1,7 +1,7 @@
Upstream-Status: Submitted
Signed-off-by: Ross Burton <ross.burton@intel.com>
-commit 1affe20d5c82befc3b1626e557409dab5343c47b
+commit ca29a9f3e689f3840426897f58aaa3974932ae78
Author: Ross Burton <ross.burton@intel.com>
Date: Mon Jul 7 12:53:35 2014 +0100
@@ -13,7 +13,7 @@ Date: Mon Jul 7 12:53:35 2014 +0100
Signed-off-by: Ross Burton <ross.burton@intel.com>
diff --git a/configure.ac b/configure.ac
-index 2daa6be..fd1cf3f 100644
+index c214638..a1ca9ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -648,6 +648,7 @@ AC_ARG_ENABLE(kdrive-kbd, AS_HELP_STRING([--enable-kdrive-kbd], [Build kbd d
@@ -24,24 +24,18 @@ index 2daa6be..fd1cf3f 100644
dnl chown/chmod to be setuid root as part of build
-@@ -1235,18 +1236,19 @@ esac
+@@ -1235,18 +1236,21 @@ esac
AM_CONDITIONAL(BUSFAULT, test x"$BUSFAULT" = xyes)
-PKG_CHECK_MODULES([XSHMFENCE], $XSHMFENCE,
- [HAVE_XSHMFENCE=yes], [HAVE_XSHMFENCE=no])
-+HAVE_XSHMFENCE=no
-+if test "x$WANT_XSHMFENCE" != "xno"; then
-+ PKG_CHECK_MODULES([XSHMFENCE], $XSHMFENCE,
-+ [HAVE_XSHMFENCE=yes], [HAVE_XSHMFENCE=no])
-
-+ if test "$WANT_XSHMFENCE,$HAVE_XSHMFENCE" = "yes,no"; then
-+ AC_MSG_ERROR([libxshmfence requested but not found.])
-+ fi
-+ AC_DEFINE(HAVE_XSHMFENCE, 1, [Have X Shared Memory Fence library])
-+ REQUIRED_LIBS="$REQUIRED_LIBS xshmfence"
+
+-AM_CONDITIONAL(XSHMFENCE, test "x$HAVE_XSHMFENCE" = xyes)
++PKG_CHECK_MODULES([XSHMFENCE], $XSHMFENCE, [HAVE_XSHMFENCE=yes], [HAVE_XSHMFENCE=no])
++if test "x$WANT_XSHMFENCE" = "xauto"; then
++ WANT_XSHMFENCE="$HAVE_XSHMFENCE"
+fi
- AM_CONDITIONAL(XSHMFENCE, test "x$HAVE_XSHMFENCE" = xyes)
-case x"$HAVE_XSHMFENCE" in
- xyes)
@@ -49,7 +43,15 @@ index 2daa6be..fd1cf3f 100644
- REQUIRED_LIBS="$REQUIRED_LIBS xshmfence"
- ;;
-esac
--
++if test "x$WANT_XSHMFENCE" = "xyes"; then
++ if test "x$HAVE_XSHMFENCE" != "xyes"; then
++ AC_MSG_ERROR([xshmfence requested but not installed.])
++ fi
++ AC_DEFINE(HAVE_XSHMFENCE, 1, [Have xshmfence support])
++ REQUIRED_LIBS="$REQUIRED_LIBS xshmfence"
++fi
+
++AM_CONDITIONAL(XSHMFENCE, [test "x$WANT_XSHMFENCE" = xyes])
case "$DRI3,$HAVE_XSHMFENCE" in
yes,yes | auto,yes)