aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--documentation/kernel-manual/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/documentation/kernel-manual/Makefile b/documentation/kernel-manual/Makefile
index 4daeaeb47c..57cfef2ef8 100644
--- a/documentation/kernel-manual/Makefile
+++ b/documentation/kernel-manual/Makefile
@@ -1,10 +1,20 @@
XSLTOPTS = --stringparam html.stylesheet style.css \
+ --stringparam chapter.autolabel 1 \
+ --stringparam appendix.autolabel A \
+ --stringparam section.autolabel 1 \
+ --stringparam section.label.includes.component.label 1 \
--xinclude
+##
+# These URI should be rewritten by your distribution's xml catalog to
+# match your localy installed XSL stylesheets.
XSL_BASE_URI = http://docbook.sourceforge.net/release/xsl/current
XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
-all: html tarball
+all: html pdf tarball
+
+pdf:
+ ../tools/poky-docbook-to-pdf kernel-manual.xml ../template
##
# These URI should be rewritten by your distribution's xml catalog to
@@ -14,15 +24,15 @@ html:
# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
# xsltproc $(XSLTOPTS) -o yocto-project-qs.html $(XSL_XHTML_URI) yocto-project-qs.xml
- xsltproc $(XSLTOPTS) -o yocto-project-kernel-manual.html yocto-project-kernel-manual-customization.xsl yocto-project-kernel-manual.xml
+ xsltproc $(XSLTOPTS) -o yocto-project-kernel-manual.html yocto-project-kernel-manual-customization.xsl kernel-manual.xml
tarball: html
- tar -cvzf yocto-project-kernel-manual.tgz yocto-project-kernel-manual.html style.css figures/yocto-project-transp.png figures/kernel-big-picture.png figures/kernel-architecture-overview.png
+ tar -cvzf yocto-project-kernel-manual.tgz yocto-project-kernel-manual.html style.css figures/kernel-title.png figures/kernel-big-picture.png figures/kernel-architecture-overview.png
validate:
xmllint --postvalid --xinclude --noout yocto-project-kernel-manual.xml
-OUTPUTS = yocto-project-kernel-manual.tgz yocto-project-kernel-manual.html
+OUTPUTS = yocto-project-kernel-manual.tgz yocto-project-kernel-manual.html yocto-project-kernel-manual.pdf
SOURCES = *.png *.xml *.css
publish: