aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-devtools/python/python/python-2.7.3-remove-bsdb-rpath.patch28
1 files changed, 16 insertions, 12 deletions
diff --git a/meta/recipes-devtools/python/python/python-2.7.3-remove-bsdb-rpath.patch b/meta/recipes-devtools/python/python/python-2.7.3-remove-bsdb-rpath.patch
index 4b8953a137..dfd346f86e 100644
--- a/meta/recipes-devtools/python/python/python-2.7.3-remove-bsdb-rpath.patch
+++ b/meta/recipes-devtools/python/python/python-2.7.3-remove-bsdb-rpath.patch
@@ -1,15 +1,14 @@
-Remove the RPTH to avoid QA issue warning.
+Remove the RPATH to avoid QA issue warning.
+RP: Added secondary unnecessary rpath to the list 2012/8/7
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
----
- setup.py | 1 -
- 1 files changed, 0 insertions(+), 1 deletions(-)
-diff --git a/setup.py b/setup.py
-index 83b5e56..1fd5487 100644
---- a/setup.py
-+++ b/setup.py
-@@ -1025,7 +1025,6 @@ class PyBuildExt(build_ext):
+
+Index: Python-2.7.3/setup.py
+===================================================================
+--- Python-2.7.3.orig/setup.py 2012-08-07 10:41:58.560132529 +0000
++++ Python-2.7.3/setup.py 2012-08-07 11:09:47.852094515 +0000
+@@ -1042,7 +1042,6 @@
exts.append(Extension('_bsddb', ['_bsddb.c'],
depends = ['bsddb.h'],
library_dirs=dblib_dir,
@@ -17,6 +16,11 @@ index 83b5e56..1fd5487 100644
include_dirs=db_incs,
libraries=dblibs))
else:
---
-1.7.4
-
+@@ -1252,7 +1251,6 @@
+ print "building dbm using bdb"
+ dbmext = Extension('dbm', ['dbmmodule.c'],
+ library_dirs=dblib_dir,
+- runtime_library_dirs=dblib_dir,
+ include_dirs=db_incs,
+ define_macros=[
+ ('HAVE_BERKDB_H', None),