aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/lib/oe/recipeutils.py4
-rwxr-xr-xscripts/devtool2
2 files changed, 3 insertions, 3 deletions
diff --git a/meta/lib/oe/recipeutils.py b/meta/lib/oe/recipeutils.py
index 09bd7fdb46..19d97b62d2 100644
--- a/meta/lib/oe/recipeutils.py
+++ b/meta/lib/oe/recipeutils.py
@@ -269,8 +269,8 @@ def get_recipe_patches(d):
def validate_pn(pn):
"""Perform validation on a recipe name (PN) for a new recipe."""
reserved_names = ['forcevariable', 'append', 'prepend', 'remove']
- if not re.match('[0-9a-z-]+', pn):
- return 'Recipe name "%s" is invalid: only characters 0-9, a-z and - are allowed' % pn
+ if not re.match('[0-9a-z-.]+', pn):
+ return 'Recipe name "%s" is invalid: only characters 0-9, a-z, - and . are allowed' % pn
elif pn in reserved_names:
return 'Recipe name "%s" is invalid: is a reserved keyword' % pn
elif pn.startswith('pn-'):
diff --git a/scripts/devtool b/scripts/devtool
index 981ff515d3..841831c410 100755
--- a/scripts/devtool
+++ b/scripts/devtool
@@ -101,7 +101,7 @@ def read_workspace():
_create_workspace(config.workspace_path, config, basepath)
logger.debug('Reading workspace in %s' % config.workspace_path)
- externalsrc_re = re.compile(r'^EXTERNALSRC(_pn-[a-zA-Z0-9-]*)? =.*$')
+ externalsrc_re = re.compile(r'^EXTERNALSRC(_pn-[^ =]+)? =.*$')
for fn in glob.glob(os.path.join(config.workspace_path, 'appends', '*.bbappend')):
pn = os.path.splitext(os.path.basename(fn))[0].split('_')[0]
with open(fn, 'r') as f: