aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-devtools/elfutils/elfutils-0.158/fixheadercheck.patch24
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.158.bb12
2 files changed, 29 insertions, 7 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils-0.158/fixheadercheck.patch b/meta/recipes-devtools/elfutils/elfutils-0.158/fixheadercheck.patch
new file mode 100644
index 0000000000..8796e9a394
--- /dev/null
+++ b/meta/recipes-devtools/elfutils/elfutils-0.158/fixheadercheck.patch
@@ -0,0 +1,24 @@
+For some binaries we can get a invalid section alignment, for example if
+sh_align = 1 and sh_addralign is 0. In the case of a zero size section like
+".note.GNU-stack", this is irrelavent as far as I can tell and we shouldn't
+error in this case.
+
+RP 2014/6/11
+
+Upstream-Status: Pending
+
+Index: elfutils-0.158/libelf/elf32_updatenull.c
+===================================================================
+--- elfutils-0.158.orig/libelf/elf32_updatenull.c 2012-12-14 22:40:48.000000000 +0000
++++ elfutils-0.158/libelf/elf32_updatenull.c 2014-06-11 16:35:43.417386291 +0000
+@@ -327,8 +327,8 @@
+ we test for the alignment of the section being large
+ enough for the largest alignment required by a data
+ block. */
+- if (unlikely (! powerof2 (shdr->sh_addralign))
+- || unlikely (shdr->sh_addralign < sh_align))
++ if (shdr->sh_size && (unlikely (! powerof2 (shdr->sh_addralign))
++ || unlikely (shdr->sh_addralign < sh_align)))
+ {
+ __libelf_seterrno (ELF_E_INVALID_ALIGN);
+ return -1;
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.158.bb b/meta/recipes-devtools/elfutils/elfutils_0.158.bb
index e4253645bf..ef3dd0bb40 100644
--- a/meta/recipes-devtools/elfutils/elfutils_0.158.bb
+++ b/meta/recipes-devtools/elfutils/elfutils_0.158.bb
@@ -25,13 +25,11 @@ SRC_URI += "\
file://core_filename.patch \
file://CVE-2014-0172.patch \
file://unwind_non_linux.patch \
-"
-
-SRC_URI += " \
- file://elf_additions.diff \
- file://mempcpy.patch \
- file://dso-link-change.patch \
- file://m4-biarch.m4-tweak-AC_RUN_IFELSE-for-cross-compiling.patch \
+ file://elf_additions.diff \
+ file://mempcpy.patch \
+ file://dso-link-change.patch \
+ file://m4-biarch.m4-tweak-AC_RUN_IFELSE-for-cross-compiling.patch \
+ file://fixheadercheck.patch \
"
# Only apply when building uclibc based target recipe