aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-core/images/initramfs-image-minimal.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-core/images/initramfs-image-minimal.bb b/meta/recipes-core/images/initramfs-image-minimal.bb
new file mode 100644
index 0000000000..24501e0446
--- /dev/null
+++ b/meta/recipes-core/images/initramfs-image-minimal.bb
@@ -0,0 +1,19 @@
+# Minimal initramfs image
+DESCRIPTION = "Minimal initramfs image used to bring up the system."
+LICENSE = "MIT"
+
+PACKAGE_INSTALL = "initramfs-framework-base initramfs-module-udev busybox udev base-passwd"
+
+# Do not pollute the initramfs image with rootfs features
+IMAGE_FEATURES = ""
+IMAGE_LINGUAS = ""
+
+IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+inherit image
+
+BAD_RECOMMENDATIONS += "busybox-syslog"
+
+# We need to set USE_DEVFS to "0" here to trigger creation of device nodes at rootfs time.
+# The reason here is that, when this initramfs is bundled into kernel, we need /dev/console
+# to be there before init is run.
+USE_DEVFS = "0"