aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-sato/puzzles/puzzles_git.bb29
1 files changed, 12 insertions, 17 deletions
diff --git a/meta/recipes-sato/puzzles/puzzles_git.bb b/meta/recipes-sato/puzzles/puzzles_git.bb
index a9daacdaf2..2c755d8df8 100644
--- a/meta/recipes-sato/puzzles/puzzles_git.bb
+++ b/meta/recipes-sato/puzzles/puzzles_git.bb
@@ -21,7 +21,7 @@ PV = "0.0+git${SRCPV}"
S = "${WORKDIR}/git"
-inherit autotools-brokensep distro_features_check pkgconfig
+inherit autotools distro_features_check pkgconfig
PACKAGECONFIG ??= "gtk3"
PACKAGECONFIG[gtk2] = "--with-gtk=2,,gtk+,"
@@ -32,46 +32,41 @@ FILES_${PN} = ""
FILES_${PN}-extra = "${prefix}/bin ${datadir}/applications"
python __anonymous () {
- var = bb.data.expand("FILES_${PN}", d, 1)
- data = d.getVar(var, True)
+ var = d.expand("FILES_${PN}")
+ data = d.getVar(var, False)
for name in ("bridges", "fifteen", "inertia", "map", "samegame", "slant"):
- data = data + " ${prefix}/bin/%s" % name
+ data = data + " ${bindir}/%s" % name
data = data + " ${datadir}/applications/%s.desktop" % name
d.setVar(var, data)
}
-
do_configure_prepend () {
+ cd ${S}
./mkfiles.pl
+ cd ${B}
}
-do_install () {
- rm -rf ${D}/*
- export prefix=${D}
- export DESTDIR=${D}
- install -d ${D}/${prefix}/bin/
- oe_runmake install
-
-
- install -d ${D}/${datadir}/applications/
+do_install_append () {
+ # net conflicts with Samba, so rename it
+ mv ${D}${bindir}/net ${D}${bindir}/puzzles-net
# Create desktop shortcuts
+ install -d ${D}/${datadir}/applications/
cd ${D}/${prefix}/bin
for prog in *; do
if [ -x $prog ]; then
# Convert prog to Title Case
- title=$(echo $prog | sed 's/\(^\| \)./\U&/g')
+ title=$(echo $prog | sed 's/puzzles-//' | sed 's/\(^\| \)./\U&/g')
echo "making ${D}/${datadir}/applications/$prog.desktop"
cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
[Desktop Entry]
Name=$title
-Exec=${prefix}/bin/$prog
+Exec=${bindir}/$prog
Icon=applications-games
Terminal=false
Type=Application
Categories=Game;
StartupNotify=true
-X-MB-SingleInstance=true
STOP
fi
done