aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/packages/opkg-utils/opkg-utils-native_svn.bb9
-rw-r--r--meta/packages/opkg-utils/opkg-utils/index-ignore-filenotfound.patch29
-rw-r--r--meta/packages/opkg-utils/opkg-utils_svn.bb13
3 files changed, 38 insertions, 13 deletions
diff --git a/meta/packages/opkg-utils/opkg-utils-native_svn.bb b/meta/packages/opkg-utils/opkg-utils-native_svn.bb
deleted file mode 100644
index b12b5456bf..0000000000
--- a/meta/packages/opkg-utils/opkg-utils-native_svn.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require opkg-utils_svn.bb
-
-RDEPENDS = ""
-
-inherit native
-
-# Avoid circular dependencies from package_ipk.bbclass
-PACKAGES = ""
-
diff --git a/meta/packages/opkg-utils/opkg-utils/index-ignore-filenotfound.patch b/meta/packages/opkg-utils/opkg-utils/index-ignore-filenotfound.patch
new file mode 100644
index 0000000000..3eb2c9349a
--- /dev/null
+++ b/meta/packages/opkg-utils/opkg-utils/index-ignore-filenotfound.patch
@@ -0,0 +1,29 @@
+If we're building an image and some package rebuilds while this is happening
+some package can be removed/added to the ipk deploy directory. The image will
+not depend on this package so we can safely ignore these cases rather than
+error out.
+
+RP - 26/8/09
+
+Index: opkg-utils/opkg-make-index
+===================================================================
+--- opkg-utils.orig/opkg-make-index 2009-08-26 17:21:26.000000000 +0100
++++ opkg-utils/opkg-make-index 2009-08-26 17:24:05.000000000 +0100
+@@ -96,6 +96,7 @@
+ files=glob(pkg_dir + '/*.ipk') + glob(pkg_dir + '/*.deb')
+ files.sort()
+ for filename in files:
++ try:
+ basename = os.path.basename(filename)
+ pkg = None
+ fnameStat = os.stat(filename)
+@@ -130,6 +131,9 @@
+ to_morgue(basename)
+ if opt_s:
+ print filename
++ except OSError:
++ sys.stderr.write("Package %s disappeared on us!\n" % (filename,))
++ continue
+
+ pkgsStampsFile = open(stamplist_filename, "w")
+ for f in pkgsStamps.keys():
diff --git a/meta/packages/opkg-utils/opkg-utils_svn.bb b/meta/packages/opkg-utils/opkg-utils_svn.bb
index c896300642..53b208db14 100644
--- a/meta/packages/opkg-utils/opkg-utils_svn.bb
+++ b/meta/packages/opkg-utils/opkg-utils_svn.bb
@@ -3,12 +3,17 @@ SECTION = "base"
PRIORITY = "optional"
LICENSE = "GPL"
RDEPENDS = "python"
-PR = "r2"
+RDEPENDS_virtclass-native = ""
+PR = "r4"
-SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=opkg-utils;proto=http"
-
-S = "${WORKDIR}/opkg-utils"
+SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=opkg-utils;proto=http \
+ file://index-ignore-filenotfound.patch;patch=1"
inherit autotools_stage
S = "${WORKDIR}/opkg-utils"
+
+# Avoid circular dependencies from package_ipk.bbclass
+PACKAGES_virtclass-native = ""
+
+BBCLASSEXTEND = "native"