aboutsummaryrefslogtreecommitdiffstats
path: root/templates
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2014-03-09 19:48:35 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2014-03-09 20:58:24 +0000
commitcd26148eed9cfd27ec42835e4ca54871c0c2bf24 (patch)
treec7ed87541a21071e92f5de3537cfccf494634ce9 /templates
parent4db9555a67c3a2c72849d1de1b5fb8daac06111a (diff)
downloadopenembedded-core-contrib-cd26148eed9cfd27ec42835e4ca54871c0c2bf24.tar.gz
Fix append list name matching
* Recipes without versions in the file name (such as alsa-state.bb) weren't having their bbappends listed. Use a regex match to fix this. * Use the prefix from the filename instead of PN, since that's how BitBake does it * List version matching bbappends first, then non-matching in muted colour Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'templates')
-rw-r--r--templates/layerindex/recipedetail.html14
1 files changed, 13 insertions, 1 deletions
diff --git a/templates/layerindex/recipedetail.html b/templates/layerindex/recipedetail.html
index dec477c1f7..658694e8db 100644
--- a/templates/layerindex/recipedetail.html
+++ b/templates/layerindex/recipedetail.html
@@ -90,7 +90,7 @@
<h2>bbappends</h2>
<p>This recipe is appended by:</p>
<table class="table table-bordered">
- {% for append in appends %}
+ {% for append in verappends %}
<tr>
<td>
<a href="{% url layer_item append.layerbranch.branch.name append.layerbranch.layer.name %}">{{ append.layerbranch.layer.name }}</a>
@@ -100,6 +100,18 @@
</td>
</tr>
{% endfor %}
+ {% for append in appends %}
+ {% if not append in verappends %}
+ <tr>
+ <td>
+ <a href="{% url layer_item append.layerbranch.branch.name append.layerbranch.layer.name %}" class="muted">{{ append.layerbranch.layer.name }}</a>
+ </td>
+ <td>
+ <a href="{{ append.vcs_web_url }}" class="muted">{{ append.filename }}</a>
+ </td>
+ </tr>
+ {% endif %}
+ {% endfor %}
</table>
{% endif %}
</div>