summaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-19 09:30:24 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-20 11:39:43 +0000
commit256749322671d2f4ea994db671d73c4de10e1723 (patch)
tree27fbf4b38dc1e0fbc907f31a5c806c38980d1b50 /scripts
parentf0d3478913b092a01eceafe0c20378cf9117f429 (diff)
downloadopenembedded-core-contrib-256749322671d2f4ea994db671d73c4de10e1723.tar.gz
recipetool; add support for python_mesonpy class
* Add support to detect the "mesonpy" build-backend for recipetool create. * Add oe-selftest case for creating a recipe for "siphash24" from pypi. https://pypi.org/project/siphash24/ This is by far the simplest recipe using the mesonpy build backend. Upstream does not provide LICENSE file(s) and we do not detect the LICENSE so don't check for that result in the test. Likewise, upstream does not define HOMEPAGE, so skip that result. Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts')
-rw-r--r--scripts/lib/recipetool/create_buildsys_python.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/scripts/lib/recipetool/create_buildsys_python.py b/scripts/lib/recipetool/create_buildsys_python.py
index a589343cfb..a807dafae5 100644
--- a/scripts/lib/recipetool/create_buildsys_python.py
+++ b/scripts/lib/recipetool/create_buildsys_python.py
@@ -739,6 +739,7 @@ class PythonPyprojectTomlRecipeHandler(PythonRecipeHandler):
"flit_core.buildapi": "python_flit_core",
"hatchling.build": "python_hatchling",
"maturin": "python_maturin",
+ "mesonpy": "python_mesonpy",
}
# setuptools.build_meta and flit declare project metadata into the "project" section of pyproject.toml
@@ -779,6 +780,8 @@ class PythonPyprojectTomlRecipeHandler(PythonRecipeHandler):
"python3-poetry-core-native",
# already provided by python_flit_core.bbclass
"python3-flit-core-native",
+ # already provided by python_mesonpy
+ "python3-meson-python-native",
]
# add here a list of known and often used packages and the corresponding bitbake package
@@ -790,6 +793,7 @@ class PythonPyprojectTomlRecipeHandler(PythonRecipeHandler):
"setuptools-scm": "python3-setuptools-scm",
"hatchling": "python3-hatchling",
"hatch-vcs": "python3-hatch-vcs",
+ "meson-python" : "python3-meson-python",
}
def __init__(self):