aboutsummaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-11-02 15:10:03 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-07 13:58:38 +0000
commitec099a32243ebc7eecd86e4bf40ed38da4af3fe5 (patch)
treea358c35c2705411e9cc06e0fdca3ff9b369ee0d4 /scripts
parentd4d491aa118b6cbe895167c62a46d883abc7b4ab (diff)
downloadopenembedded-core-contrib-ec099a32243ebc7eecd86e4bf40ed38da4af3fe5.tar.gz
scripts/combo-layer: tidy up config example
Move all example configuration to the example config file, tidy up a few long lines and fix some grammar. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/combo-layer47
-rw-r--r--scripts/combo-layer.conf.example23
2 files changed, 19 insertions, 51 deletions
diff --git a/scripts/combo-layer b/scripts/combo-layer
index db38a95805..e39e4e013f 100755
--- a/scripts/combo-layer
+++ b/scripts/combo-layer
@@ -42,52 +42,7 @@ class Configuration(object):
"""
Manages the configuration
- A valid conf looks like:
-
-# component name
-[bitbake]
-
-# mandatory options
-
-# git upstream uri
-src_uri = git://git.openembedded.org/bitbake
-
-# the directory to clone the component repo
-local_repo_dir = ~/src/bitbake
-
-# the relative dir to commit the repo patch
-# use "." if it is root dir
-dest_dir = bitbake
-
-# the updated revision last time.
-# leave it empty if no commit updated yet, and then the tool
-# will start from the first commit
-last_revision =
-
-# optional options
-
-# file_filter: only include the interested file
-# file_filter = [path] [path] ...
-# example:
-# file_filter = src/ : only include the subdir src
-# file_filter = src/*.c : only include the src *.c file
-# file_filter = src/main.c src/Makefile.am : only include these two files
-
-[oe-core]
-src_uri = git://git.openembedded.org/openembedded-core
-local_repo_dir = ~/src/oecore
-dest_dir = .
-last_revision =
-
-# it's also possible to embed python code in the config values. Similar
-# to bitbake it considers every value starting with @ to be a python script.
-# So local_repo could be easily configured using an environment variable as:
-#
-# [bitbake]
-# local_repo = @os.getenv("LOCAL_REPO_DIR") + "/bitbake"
-#
-
-# more components ...
+ For an example config file, see combo-layer.conf.example
"""
def __init__(self, options):
diff --git a/scripts/combo-layer.conf.example b/scripts/combo-layer.conf.example
index 8cee04f771..3865829606 100644
--- a/scripts/combo-layer.conf.example
+++ b/scripts/combo-layer.conf.example
@@ -1,3 +1,5 @@
+# combo-layer example configuration file
+
# component name
[bitbake]
# mandatory options
@@ -7,8 +9,8 @@ src_uri = git://git.openembedded.org/bitbake
# the directory to clone the component repo
local_repo_dir = /home/kyu3/src/test/bitbake
-# the relative dir to commit the repo patch
-# use "." if it is root dir
+# the relative dir within the combo repo to put the component files
+# use "." if the files should be in the root dir
dest_dir = bitbake
# the last update revision.
@@ -25,9 +27,10 @@ last_revision =
# file_filter = src/*.c : only include the src *.c file
# file_filter = src/main.c src/Makefile.am : only include these two files
-# hook: if provided, the tool will call the hook to process the generated patch from upstream,
-# and then apply the modified patch to combo repo
-# the hook's parameter is: ./hook patchpath revision reponame
+# hook: if provided, the tool will call the hook to process the generated
+# patch from upstream, and then apply the modified patch to the combo
+# repo.
+# the hook script is called as follows: ./hook patchpath revision reponame
# example:
# hook = combo-layer-hook-default.sh
@@ -36,3 +39,13 @@ src_uri = git://git.openembedded.org/openembedded-core
local_repo_dir = /home/kyu3/src/test/oecore
dest_dir = .
last_revision =
+
+# It is also possible to embed python code in the config values. Similar
+# to bitbake it considers every value starting with @ to be a python
+# script.
+# e.g. local_repo_dir could easily be configured using an environment
+# variable:
+#
+# [bitbake]
+# local_repo_dir = @os.getenv("LOCAL_REPO_DIR") + "/bitbake"
+#