aboutsummaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2008-11-04 19:35:06 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2008-11-04 19:35:06 +0000
commit9586e75e2693abdc795d5e641aff553b14957914 (patch)
treea7076f5cf6199cb9ee197040bbe26ff4c9e36731 /scripts
parentf869e706abd96ca0b0b3b336f428ac94619586ed (diff)
downloadopenembedded-core-contrib-9586e75e2693abdc795d5e641aff553b14957914.tar.gz
scripts/poky-autobuild-moblin: Update the proxy config and add rpm packages to the build list
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/poky-autobuild-moblin8
1 files changed, 5 insertions, 3 deletions
diff --git a/scripts/poky-autobuild-moblin b/scripts/poky-autobuild-moblin
index 0fa2ba0f0a..afd85964be 100755
--- a/scripts/poky-autobuild-moblin
+++ b/scripts/poky-autobuild-moblin
@@ -49,7 +49,7 @@ fi
BDIR="build"
. ./scripts/poky-env-internal
-BB_ENV_EXTRAWHITE="$BB_ENV_EXTRAWHITE GIT_CORE_CONFIG GIT_PROXY_IGNORE_1 GIT_PROXY_HOST GIT_PROXY_PORT"
+BB_ENV_EXTRAWHITE="$BB_ENV_EXTRAWHITE"
POSTPROCESS=`which poky-autobuild-postprocess-moblin`
if [ "xcomplete" = "x$1" ]; then
@@ -68,12 +68,12 @@ if [ ! -e "$CONFFILE" ]; then
if [ ! -d "./conf" ]; then
mkdir -p "./conf"
fi
- echo 'PACKAGE_CLASSES = "package_ipk package_deb"' > "$CONFFILE"
+ echo 'PACKAGE_CLASSES = "package_ipk package_deb package_rpm"' > "$CONFFILE"
echo 'BB_NUMBER_THREADS = "6"' >> "$CONFFILE"
echo 'PARALLEL_MAKE = "-j 6"' >> "$CONFFILE"
echo "DL_DIR = \"$SRVWORKDIR/sources\"" >> "$CONFFILE"
echo 'INHERIT += "poky-autobuild-notifier"' >> "$CONFFILE"
- echo 'GIT_PROXY_COMMAND=poky-git-proxy-socks-command' >> "$CONFFILE"
+ echo 'INHERIT += "poky-moblin-autobuilder-proxy-config"' >> "$CONFFILE"
if [ "$ABTARGET" = "darwin" ]; then
echo 'PACKAGE_CLASSES += "package_tar"' >> "$CONFFILE"
echo "BBFILES += \"$CURRDIR/meta-darwin/packages/*/*.bb\"" >> "./conf/local.conf"
@@ -84,6 +84,8 @@ if [ ! -e "$CONFFILE" ]; then
fi
fi
+BBPATH=$SRVWORKDIR/localmeta:$BBPATH
+
if [ "$ABTARGET" = "darwin" ]; then
BBPATH=$CURRDIR/meta-darwin:$BBPATH
fi