summaryrefslogtreecommitdiffstats
path: root/scripts/poky-autobuild
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-05-01 13:14:17 +0000
committerRichard Purdie <richard@openedhand.com>2008-05-01 13:14:17 +0000
commitd367e44e3f405a54ddc4bf16d0bbdbb5bc82fd55 (patch)
tree84ff6b72479556281885ffef1d87a0d867381716 /scripts/poky-autobuild
parentc8121240a551d57904315a96a315967b3d92b4f6 (diff)
downloadopenembedded-core-contrib-d367e44e3f405a54ddc4bf16d0bbdbb5bc82fd55.tar.gz
scripts/poky-autobuild: Correctly update the extra meta-darwin checkout
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4397 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'scripts/poky-autobuild')
-rwxr-xr-xscripts/poky-autobuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/scripts/poky-autobuild b/scripts/poky-autobuild
index 47dba812c8..bd2a752db4 100755
--- a/scripts/poky-autobuild
+++ b/scripts/poky-autobuild
@@ -30,6 +30,13 @@ elif [ "$CURRDIR" = "/srv/poky/autobuild/incremental-shihtzu/build" ]; then
ABTARGET="incremental"
elif [ "$CURRDIR" = "/srv/poky/autobuild/full-darwin-shihtzu/build" ]; then
ABTARGET="darwin"
+ if [ ! -d "$CURRDIR/meta-darwin" ]; then
+ svn co http://svn.o-hand.com/repos/poky/branches/experimental/meta-darwin $CURRDIR/meta-darwin
+ else
+ cd $CURRDIR/meta-darwin
+ svn up
+ cd $CURRDIR
+ fi
fi
if [ "xpreamble" = "x$1" ]; then
@@ -64,12 +71,6 @@ if [ ! -e "$CONFFILE" ]; then
echo 'PARALLEL_MAKE = "-j 6"' >> "$CONFFILE"
echo 'DL_DIR = "/srv/poky/sources"' >> "$CONFFILE"
if [ "$ABTARGET" = "darwin" ]; then
- if [ ! -d "$CURRDIR/meta-darwin" ]; then
- svn co http://svn.o-hand.com/repos/poky/branches/experimental/meta-darwin $CURRDIR/meta-darwin
- else
- cd $CURRDIR/meta-darwin
- svn up
- fi
echo 'PACKAGE_CLASSES += "package_tar"' >> "$CONFFILE"
echo "BBFILES += \"$CURRDIR/meta-darwin/packages/*/*.bb\"" >> "./conf/local.conf"
echo 'POKYMODE = "darwin"' >> "$CONFFILE"