aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/lib
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-04-21 08:45:41 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-29 07:34:11 +0100
commitbdb5a6a5b3c31ed44bed8321f5febb6a09dfb9f2 (patch)
treeb052e1b400b207ac5728e41cb024e7ce21d864fd /scripts/lib
parent404c9e38f1b133ebd5f7b74875910d9e6cbc59e9 (diff)
downloadopenembedded-core-contrib-bdb5a6a5b3c31ed44bed8321f5febb6a09dfb9f2.tar.gz
recipetool.newappend: fix syntax error for 'not path_ok' error
Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'scripts/lib')
-rw-r--r--scripts/lib/recipetool/newappend.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/lib/recipetool/newappend.py b/scripts/lib/recipetool/newappend.py
index bdf0693ec7..4fbb40a358 100644
--- a/scripts/lib/recipetool/newappend.py
+++ b/scripts/lib/recipetool/newappend.py
@@ -81,7 +81,7 @@ def newappend(args):
return 1
if not path_ok:
- logger.warn('Unable to determine correct subdirectory path for bbappend file - check that what %s adds to BBFILES also matches .bbappend files. Using %s for now, but until you fix this the bbappend will not be applied.', os.path.join(destlayerdir, 'conf', 'layer.conf'), os.path.dirname(appendpath))
+ logger.warn('Unable to determine correct subdirectory path for bbappend file - check that what %s adds to BBFILES also matches .bbappend files. Using %s for now, but until you fix this the bbappend will not be applied.', os.path.join(args.destlayer, 'conf', 'layer.conf'), os.path.dirname(append_path))
layerdirs = [os.path.abspath(layerdir) for layerdir in rd.getVar('BBLAYERS', True).split()]
if not os.path.abspath(args.destlayer) in layerdirs: