aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/lib
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2017-08-31 11:54:17 +1200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-31 23:25:33 +0100
commitb48c48b00e82491d1c69e4d89a79c6242361abec (patch)
treed743084fc464165441aa2d4953eb7aca838f1694 /scripts/lib
parentf49042e707d641b59a71c687374b76df97c64c34 (diff)
downloadopenembedded-core-contrib-b48c48b00e82491d1c69e4d89a79c6242361abec.tar.gz
scriptutils: fix fetch_url() to use lowercase dummy recipe name
recipetool create (and hence devtool add) and devtool upgrade use fetch_url() which creates a dummy recipe in order to fetch source. Previously the random part of the name was using uppercase characters, and this triggers a QA warning after OE-Core commit 4713f8b2c4f2c74239d284adcf1e59e61aa66576, so use lowercase instead as I really should have in the first place. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts/lib')
-rw-r--r--scripts/lib/scriptutils.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/lib/scriptutils.py b/scripts/lib/scriptutils.py
index 11f1a78e97..85b1c949bf 100644
--- a/scripts/lib/scriptutils.py
+++ b/scripts/lib/scriptutils.py
@@ -134,7 +134,7 @@ def fetch_url(tinfoil, srcuri, srcrev, destdir, logger, preserve_tmp=False, mirr
# for do_fetch and do_unpack
# I'd use tempfile functions here but underscores can be produced by that and those
# aren't allowed in recipe file names except to separate the version
- rndstring = ''.join(random.choice(string.ascii_uppercase + string.digits) for _ in range(8))
+ rndstring = ''.join(random.choice(string.ascii_lowercase + string.digits) for _ in range(8))
fetchrecipe = os.path.join(fetchrecipedir, 'tmp-recipetool-%s.bb' % rndstring)
fetchrecipepn = os.path.splitext(os.path.basename(fetchrecipe))[0]
logger.debug('Generating initial recipe %s for fetching' % fetchrecipe)