aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/lib
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2017-11-13 10:49:06 +1300
committerPaul Eggleton <paul.eggleton@linux.intel.com>2017-11-13 10:59:08 +1300
commit5c396e4795c8314caa84c2f6cc2842f53f59dfaf (patch)
tree9d0624cbd45ac0ac03a7d0d1cac9142706e08068 /scripts/lib
parenta17f3ec910366e9e7551fa24fbc07929b9584341 (diff)
downloadopenembedded-core-contrib-paule/recipetool-fix2.tar.gz
recipetool: create: fix failure handling included dictspaule/recipetool-fix2
If a setup dict in a python setup.py file pulled in the contents of another dict (e.g. **otherdict), then we got an error when mapping the keys because the key is None in that case. Skip those keys to avoid the error (we pick up the values directly in any case). A quick reproducer for this issue: recipetool create https://files.pythonhosted.org/packages/source/p/pyqtgraph/pyqtgraph-0.10.0.tar.gz Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'scripts/lib')
-rw-r--r--scripts/lib/recipetool/create_buildsys_python.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/scripts/lib/recipetool/create_buildsys_python.py b/scripts/lib/recipetool/create_buildsys_python.py
index ec5449bee9..5bd2aa337c 100644
--- a/scripts/lib/recipetool/create_buildsys_python.py
+++ b/scripts/lib/recipetool/create_buildsys_python.py
@@ -356,6 +356,8 @@ class PythonRecipeHandler(RecipeHandler):
# Naive mapping of setup() arguments to PKG-INFO field names
for d in [info, non_literals]:
for key, value in list(d.items()):
+ if key is None:
+ continue
new_key = _map(key)
if new_key != key:
del d[key]