aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/combo-layer
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-11-02 15:10:03 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-07 13:58:38 +0000
commitec099a32243ebc7eecd86e4bf40ed38da4af3fe5 (patch)
treea358c35c2705411e9cc06e0fdca3ff9b369ee0d4 /scripts/combo-layer
parentd4d491aa118b6cbe895167c62a46d883abc7b4ab (diff)
downloadopenembedded-core-contrib-ec099a32243ebc7eecd86e4bf40ed38da4af3fe5.tar.gz
scripts/combo-layer: tidy up config example
Move all example configuration to the example config file, tidy up a few long lines and fix some grammar. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'scripts/combo-layer')
-rwxr-xr-xscripts/combo-layer47
1 files changed, 1 insertions, 46 deletions
diff --git a/scripts/combo-layer b/scripts/combo-layer
index db38a95805..e39e4e013f 100755
--- a/scripts/combo-layer
+++ b/scripts/combo-layer
@@ -42,52 +42,7 @@ class Configuration(object):
"""
Manages the configuration
- A valid conf looks like:
-
-# component name
-[bitbake]
-
-# mandatory options
-
-# git upstream uri
-src_uri = git://git.openembedded.org/bitbake
-
-# the directory to clone the component repo
-local_repo_dir = ~/src/bitbake
-
-# the relative dir to commit the repo patch
-# use "." if it is root dir
-dest_dir = bitbake
-
-# the updated revision last time.
-# leave it empty if no commit updated yet, and then the tool
-# will start from the first commit
-last_revision =
-
-# optional options
-
-# file_filter: only include the interested file
-# file_filter = [path] [path] ...
-# example:
-# file_filter = src/ : only include the subdir src
-# file_filter = src/*.c : only include the src *.c file
-# file_filter = src/main.c src/Makefile.am : only include these two files
-
-[oe-core]
-src_uri = git://git.openembedded.org/openembedded-core
-local_repo_dir = ~/src/oecore
-dest_dir = .
-last_revision =
-
-# it's also possible to embed python code in the config values. Similar
-# to bitbake it considers every value starting with @ to be a python script.
-# So local_repo could be easily configured using an environment variable as:
-#
-# [bitbake]
-# local_repo = @os.getenv("LOCAL_REPO_DIR") + "/bitbake"
-#
-
-# more components ...
+ For an example config file, see combo-layer.conf.example
"""
def __init__(self, options):