summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-02-21 12:45:56 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-22 23:51:46 +0000
commite597fe76a710cc6bb833ee50c235c5c565eb23fa (patch)
treef51d6c8735362ff5467fe3f31ebf909d5c018250 /meta
parentd320a03b697679dfe223883b23480b70f89ad649 (diff)
downloadopenembedded-core-contrib-e597fe76a710cc6bb833ee50c235c5c565eb23fa.tar.gz
linux-yocto: fix PV
For whatever reason, the creation of the 5.4 recipes missed the PV that we've always had in linux-yocto. PV follows the LINUX_VERSION variable and clearly indicates that we have git commits in our tree above the -stable releases. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_5.4.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.4.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_5.4.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_5.4.bb b/meta/recipes-kernel/linux/linux-yocto-rt_5.4.bb
index fc31dc869a..ab93f1bf55 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_5.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_5.4.bb
@@ -24,7 +24,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
DEPENDS += "openssl-native util-linux-native"
-PV = "5.4.15"
+PV = "${LINUX_VERSION}+git${SRCPV}"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.4.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.4.bb
index cfecf986fb..097357d9c0 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.4.bb
@@ -19,7 +19,7 @@ SRCREV_machine_qemuarm ?= "3805e4f98313c4a4c64ffdb06b6401de8746fe45"
SRCREV_machine ?= "2358d789229f8d80ebe4b3e35d3819c4f0e00926"
SRCREV_meta ?= "c11911d4d1cf0d0b069dfd1922b41256f61442de"
-PV = "5.4.15"
+PV = "${LINUX_VERSION}+git${SRCPV}"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.4;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_5.4.bb b/meta/recipes-kernel/linux/linux-yocto_5.4.bb
index aa17380d00..0b2a2305f1 100644
--- a/meta/recipes-kernel/linux/linux-yocto_5.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_5.4.bb
@@ -35,7 +35,7 @@ LINUX_VERSION ?= "5.4.20"
DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
DEPENDS += "openssl-native util-linux-native"
-PV = "5.4.15"
+PV = "${LINUX_VERSION}+git${SRCPV}"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"