aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2019-01-23 22:33:02 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-24 17:45:18 +0000
commit70859e12a1ea17a6b924f720f3677adcb7e87e0a (patch)
treeb2bbd288bf10398189b3faabae7341dc99a70740 /meta
parentea3526961920a229e0bb5fb459952be89fce2255 (diff)
downloadopenembedded-core-contrib-70859e12a1ea17a6b924f720f3677adcb7e87e0a.tar.gz
perl: Make install.perl depend on install.sym
Fixed a race issue when do_install: Generating wrapper script for /path/to/8.1-r0/image/path/to/8.1-r0/recipe-sysroot-native/usr/bin/perl-native/perl5.28.1 mv: cannot stat /path/to/8.1-r0/image/path/to/8.1-r0/recipe-sysroot-native/usr/bin/perl-native/perl5.28.1: No such file or directory Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/perl-sanity/files/0001-Makefile-Make-install.perl-depend-on-install.sym.patch32
-rw-r--r--meta/recipes-devtools/perl-sanity/perl_5.28.1.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl-sanity/files/0001-Makefile-Make-install.perl-depend-on-install.sym.patch b/meta/recipes-devtools/perl-sanity/files/0001-Makefile-Make-install.perl-depend-on-install.sym.patch
new file mode 100644
index 0000000000..1267339978
--- /dev/null
+++ b/meta/recipes-devtools/perl-sanity/files/0001-Makefile-Make-install.perl-depend-on-install.sym.patch
@@ -0,0 +1,32 @@
+From a0a2fcac3735ca90017976d2b87f550d051a969b Mon Sep 17 00:00:00 2001
+From: Robert Yang <liezhi.yang@windriver.com>
+Date: Tue, 22 Jan 2019 19:21:27 -0800
+Subject: [PATCH] Makefile: Make install.perl depend on install.sym
+
+Fix a race issue when install, there might be no
+$(installbin)/$(perlname)$(version) when install.sym runs after install.perl
+since install.sym removes it.
+
+Upstream-Status: Submitted [https://github.com/arsv/perl-cross/pull/73]
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index cd8d75f..1aa8ef2 100644
+--- a/Makefile
++++ b/Makefile
+@@ -406,7 +406,7 @@ META.yml: Porting/makemeta Porting/Maintainers.pl Porting/Maintainers.pm miniper
+
+ install: install.perl install.sym install.man
+
+-install.perl: installperl | miniperl$X
++install.perl: installperl install.sym | miniperl$X
+ ./miniperl_top installperl --destdir=$(DESTDIR) $(INSTALLFLAGS) $(STRIPFLAGS)
+ -@test ! -s extras.lst || $(MAKE) extras.install
+
+--
+2.10.2
+
diff --git a/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb b/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb
index 176980e1b2..a2ec264100 100644
--- a/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb
+++ b/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb
@@ -23,6 +23,7 @@ SRC_URI = "https://www.cpan.org/src/5.0/perl-${PV}.tar.gz;name=perl \
file://fix-race-failures-2.patch \
file://0001-Also-build-dynaloader-separately-as-race-failures-ha.patch \
file://0001-Make-sure-install.perl-runs-before-install.man.patch \
+ file://0001-Makefile-Make-install.perl-depend-on-install.sym.patch \
"
SRC_URI[perl.md5sum] = "838198c43d4f39d7af797e2f59c2bee5"