aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2019-02-19 09:10:33 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-20 11:30:26 +0000
commit4975a283478ec3cbde813a1b27ab318de4aa8051 (patch)
tree92bd9a2a879da48253d6ababe4dfa139dba9c09f /meta
parent53b5629cf5010f8fee79d82260e291b418cbef7c (diff)
downloadopenembedded-core-contrib-4975a283478ec3cbde813a1b27ab318de4aa8051.tar.gz
python3: fix INCLDIRSTOMAKE in _sysconfigdata.py
recipe glade do_configure failed after python upgrade to 3.7.2, it will do runtime check of python headers with native python3 under recipe-sysroot-native, it will check under path INCLDIRSTOMAKE, but this value is '/usr/include /usr/include /usr/include/python3.7m /usr/include/python3.7m', which will cause below error: ERROR: This autoconf log indicates errors, it looked at host include and/or library paths while determining system capabilities. fix it by replace /usr/include to STAGING_INCDIR Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python3_3.7.2.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3_3.7.2.bb b/meta/recipes-devtools/python/python3_3.7.2.bb
index 8f9d7dc8fe..4a1cbae867 100644
--- a/meta/recipes-devtools/python/python3_3.7.2.bb
+++ b/meta/recipes-devtools/python/python3_3.7.2.bb
@@ -124,6 +124,8 @@ do_install_append() {
-e "s,^ 'LIBDIR'.*, 'LIBDIR': '${STAGING_LIBDIR}'\,,g" \
-e "s,^ 'INCLUDEDIR'.*, 'INCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
-e "s,^ 'CONFINCLUDEDIR'.*, 'CONFINCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
+ -e "/^ 'INCLDIRSTOMAKE'/{N; s,/usr/include,${STAGING_INCDIR},g}" \
+ -e "/^ 'INCLUDEPY'/s,/usr/include,${STAGING_INCDIR},g" \
${D}${libdir}/python-sysconfigdata/_sysconfigdata.py
}