aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-01-23 17:17:37 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-24 17:45:28 +0000
commit3ae634853a034a322593d318502ea2ee799556f7 (patch)
treed918e658248f3ae89c3b9da5da589f24d2cc4b71 /meta
parent9ac7415464b7817aa5cc0c2167ff61f4344660dd (diff)
downloadopenembedded-core-contrib-3ae634853a034a322593d318502ea2ee799556f7.tar.gz
qemuwrapper-cross: check qemu usermode only when building a target package
When building nativesdk- package, MACHINE_FEATURES do not apply as they are specified only for target machines, not ones hosting the sdk. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb b/meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb
index 06f15617df..a0448a1803 100644
--- a/meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb
+++ b/meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb
@@ -20,7 +20,7 @@ do_install () {
#!/bin/sh
set -x
-if [ ${@bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', 'True', 'False', d)} = False ]; then
+if [ ${@bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', 'True', 'False', d)} = False -a "${PN}" != "nativesdk-qemuwrapper-cross" ]; then
echo "qemuwrapper: qemu usermode is not supported"
exit 1
fi