summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-10-14 15:08:59 +0100
committerArmin Kuster <akuster808@gmail.com>2019-11-10 14:11:42 -0800
commitb5f8274d75cb61beaf7dab3420bda206e45697ae (patch)
tree1a903fe5ac58711cffdb4ed73b2ed226e23cb477 /meta
parenta1d9cfef7f247d616cd6ca482916ad0469e4fc58 (diff)
downloadopenembedded-core-contrib-b5f8274d75cb61beaf7dab3420bda206e45697ae.tar.gz
qemu-helper-native: pass compiler flags
Pass all of the compiler and linker flags so the build is correctly configured. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb b/meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb
index d9d9da0fad..372eebd886 100644
--- a/meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb
+++ b/meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb
@@ -12,7 +12,7 @@ S = "${WORKDIR}"
inherit native
do_compile() {
- ${CC} tunctl.c -o tunctl
+ ${CC} ${CFLAGS} ${LDFLAGS} -Wall tunctl.c -o tunctl
}
do_install() {