summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-11-04 12:14:57 +0000
committerArmin Kuster <akuster808@gmail.com>2019-11-10 14:01:24 -0800
commit4668ac8c2600fe5698f030ed1e8cba69c0989a2c (patch)
treee73363027f2481136a1fd7baa347c3ee99faefa7 /meta
parent2435c38e109cac68476ee672eca09b4cd6237ed4 (diff)
downloadopenembedded-core-contrib-4668ac8c2600fe5698f030ed1e8cba69c0989a2c.tar.gz
file: run test suite when building natively
As we apply the same patches to native and target builds of file, we can verify that the patches are not breaking by executing the test suite during the build of file-native. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/file/file_5.37.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.37.bb b/meta/recipes-devtools/file/file_5.37.bb
index 509b6cea6e..60fc66131e 100644
--- a/meta/recipes-devtools/file/file_5.37.bb
+++ b/meta/recipes-devtools/file/file_5.37.bb
@@ -32,6 +32,10 @@ EXTRA_OEMAKE_append_class-nativesdk = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/
FILES_${PN} += "${datadir}/misc/*.mgc"
+do_compile_append_class-native() {
+ oe_runmake check
+}
+
do_install_append_class-native() {
create_cmdline_wrapper ${D}/${bindir}/file \
--magic-file ${datadir}/misc/magic.mgc