aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-03 15:54:29 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-05 13:14:52 +0000
commitbd73fa69f532ca3d81ec2452a79e7a333b3543c2 (patch)
treef2f560a066aeb717bcbcbba29bb6bb04b40ac3ce /meta
parentdb1d22ab3853089e0012b51b8c1946a2a0a94375 (diff)
downloadopenembedded-core-contrib-bd73fa69f532ca3d81ec2452a79e7a333b3543c2.tar.gz
recipes: Fix ALLOW_EMPTY with no package specified
There are various usages of ALLOW_EMPTY with no packages specified. This is not recommended syntax, nor is it likely to be supported in the future. This patch improves the references in OE-Core, either removing them if they're pointless (e.g. when PACKAGES="") or specifying which package it applies to. (From OE-Core rev: fe81bd4f600877e63433184cfc2e22c33bb77db6) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-connectivity/openssl/ocf-linux.inc2
-rw-r--r--meta/recipes-core/meta/package-index.bb1
-rw-r--r--meta/recipes-devtools/installer/adt-installer_1.0.bb2
-rw-r--r--meta/recipes-extended/psmisc/psmisc.inc2
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-meta-base_0.10.bb6
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-plugins-package.inc2
6 files changed, 7 insertions, 8 deletions
diff --git a/meta/recipes-connectivity/openssl/ocf-linux.inc b/meta/recipes-connectivity/openssl/ocf-linux.inc
index dba1f029ac..4efdc2f6f9 100644
--- a/meta/recipes-connectivity/openssl/ocf-linux.inc
+++ b/meta/recipes-connectivity/openssl/ocf-linux.inc
@@ -20,5 +20,5 @@ do_install() {
install -m 0644 ${S}/ocf/*.h ${D}${includedir}/crypto/
}
-ALLOW_EMPTY = "1"
+ALLOW_EMPTY_${PN} = "1"
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-core/meta/package-index.bb b/meta/recipes-core/meta/package-index.bb
index 99ac1a8645..76bf331fc7 100644
--- a/meta/recipes-core/meta/package-index.bb
+++ b/meta/recipes-core/meta/package-index.bb
@@ -2,7 +2,6 @@ DESCRIPTION = "Rebuild the package index"
LICENSE = "MIT"
INHIBIT_DEFAULT_DEPS = "1"
-ALLOW_EMPTY = "1"
PACKAGES = ""
do_fetch[noexec] = "1"
diff --git a/meta/recipes-devtools/installer/adt-installer_1.0.bb b/meta/recipes-devtools/installer/adt-installer_1.0.bb
index 227e866861..0cc3b3356b 100644
--- a/meta/recipes-devtools/installer/adt-installer_1.0.bb
+++ b/meta/recipes-devtools/installer/adt-installer_1.0.bb
@@ -26,8 +26,6 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
LICENSE = "MIT"
-ALLOW_EMPTY = "1"
-
PACKAGES = ""
PR = "r11"
diff --git a/meta/recipes-extended/psmisc/psmisc.inc b/meta/recipes-extended/psmisc/psmisc.inc
index 76af99e8a8..68e06561f9 100644
--- a/meta/recipes-extended/psmisc/psmisc.inc
+++ b/meta/recipes-extended/psmisc/psmisc.inc
@@ -15,7 +15,7 @@ S = "${WORKDIR}/psmisc-${PV}"
inherit autotools gettext
-ALLOW_EMPTY = "1"
+ALLOW_EMPTY_${PN} = "1"
PACKAGES =+ "fuser fuser-doc killall killall-doc pstree pstree-doc"
PACKAGES += "psmisc-extras"
diff --git a/meta/recipes-multimedia/gstreamer/gst-meta-base_0.10.bb b/meta/recipes-multimedia/gstreamer/gst-meta-base_0.10.bb
index 37c70c2190..210da3745e 100644
--- a/meta/recipes-multimedia/gstreamer/gst-meta-base_0.10.bb
+++ b/meta/recipes-multimedia/gstreamer/gst-meta-base_0.10.bb
@@ -14,7 +14,11 @@ PACKAGES = "\
gst-meta-debug \
gst-meta-video"
-ALLOW_EMPTY = "1"
+ALLOW_EMPTY_gst-meta-base = "1"
+ALLOW_EMPTY_gst-meta-x11-base = "1"
+ALLOW_EMPTY_gst-meta-audio = "1"
+ALLOW_EMPTY_gst-meta-debug = "1"
+ALLOW_EMPTY_gst-meta-video = "1"
RDEPENDS_gst-meta-base = "\
${@base_contains('DISTRO_FEATURES', 'x11', 'gst-meta-x11-base', '', d)} \
diff --git a/meta/recipes-multimedia/gstreamer/gst-plugins-package.inc b/meta/recipes-multimedia/gstreamer/gst-plugins-package.inc
index f26aca5c85..3e9ef92fdd 100644
--- a/meta/recipes-multimedia/gstreamer/gst-plugins-package.inc
+++ b/meta/recipes-multimedia/gstreamer/gst-plugins-package.inc
@@ -24,8 +24,6 @@ python populate_packages_prepend () {
d.setVar('DESCRIPTION_' + metapkg, pn + ' meta package')
}
-ALLOW_EMPTY = "1"
-
PACKAGES += "${PN}-apps ${PN}-meta ${PN}-glib"
FILES_${PN}-apps = "${bindir}"