aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2014-08-04 11:10:02 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-06 10:03:21 +0100
commit1d75145f98d534ca8372766f825e1dd3162d669c (patch)
treea04a58286e36bcf9d88fa7ebd55d3ad063566f76 /meta
parent1805ec85c6f466b81d6aa547e90d457ef4534d5d (diff)
downloadopenembedded-core-contrib-1d75145f98d534ca8372766f825e1dd3162d669c.tar.gz
tcp-wrappers: fix do_install when $prefix == $base_prefix
(From OE-Core rev: ebc2b2f7d256ab1f05b9fe8af414c6425f9a2bf1) Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/tcp-wrappers/tcp-wrappers_7.6.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta/recipes-extended/tcp-wrappers/tcp-wrappers_7.6.bb b/meta/recipes-extended/tcp-wrappers/tcp-wrappers_7.6.bb
index c7954e7ccd..11cc243e6d 100644
--- a/meta/recipes-extended/tcp-wrappers/tcp-wrappers_7.6.bb
+++ b/meta/recipes-extended/tcp-wrappers/tcp-wrappers_7.6.bb
@@ -87,10 +87,12 @@ do_install () {
oe_libinstall -a libwrap ${D}${libdir}
oe_libinstall -C shared -so libwrap ${D}${base_libdir}
- rel_lib_prefix=`echo ${libdir} | sed 's,\(^/\|\)[^/][^/]*,..,g'`
- libname=`readlink ${D}${base_libdir}/libwrap.so | xargs basename`
- ln -s ${rel_lib_prefix}${base_libdir}/${libname} ${D}${libdir}/libwrap.so
- rm -f ${D}${base_libdir}/libwrap.so
+ if [ "${libdir}" != "${base_libdir}" ] ; then
+ rel_lib_prefix=`echo ${libdir} | sed 's,\(^/\|\)[^/][^/]*,..,g'`
+ libname=`readlink ${D}${base_libdir}/libwrap.so | xargs basename`
+ ln -s ${rel_lib_prefix}${base_libdir}/${libname} ${D}${libdir}/libwrap.so
+ rm -f ${D}${base_libdir}/libwrap.so
+ fi
install -d ${D}${sbindir}
for b in ${BINS}; do