aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2013-06-24 09:45:49 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-25 17:44:59 +0100
commit051eb15093fe6df7b9efe6744ce50da7d15269e4 (patch)
treecf41e84322cb1f658e61b5a7d38954c3cad05f21 /meta
parent316e24233c26513203c461799268982cb0be9281 (diff)
downloadopenembedded-core-contrib-051eb15093fe6df7b9efe6744ce50da7d15269e4.tar.gz
buildtools-tarball: Add nativesdk-make
Recently it was discovered that many Fedora hosts have a broken version of make 3.82. Add make to the buildtools-tarball, as well ad modify make to support building a special nativesdk version. (From OE-Core rev: ea972fc4ce2268f01be6beeafd27dd949d800f9d) Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/meta/buildtools-tarball.bb3
-rw-r--r--meta/recipes-devtools/make/make_3.82.bb2
2 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-core/meta/buildtools-tarball.bb b/meta/recipes-core/meta/buildtools-tarball.bb
index 387db75373..8b68f716c5 100644
--- a/meta/recipes-core/meta/buildtools-tarball.bb
+++ b/meta/recipes-core/meta/buildtools-tarball.bb
@@ -1,4 +1,4 @@
-DESCRIPTION = "SDK type target for building a standalone tarball containing python, chrpath, git and tar. The \
+DESCRIPTION = "SDK type target for building a standalone tarball containing python, chrpath, make, git and tar. The \
tarball can be used to run bitbake builds on systems which don't meet the usual version requirements."
SUMMARY = "Standalone tarball for running builds on systems with inadequate software"
LICENSE = "MIT"
@@ -36,6 +36,7 @@ TOOLCHAIN_HOST_TASK ?= "\
nativesdk-chrpath \
nativesdk-tar \
nativesdk-git \
+ nativesdk-make \
"
TOOLCHAIN_OUTPUTNAME ?= "${SDK_NAME}-buildtools-nativesdk-standalone-${DISTRO_VERSION}"
diff --git a/meta/recipes-devtools/make/make_3.82.bb b/meta/recipes-devtools/make/make_3.82.bb
index 8a2f287a01..6cc467d547 100644
--- a/meta/recipes-devtools/make/make_3.82.bb
+++ b/meta/recipes-devtools/make/make_3.82.bb
@@ -13,4 +13,4 @@ SRC_URI += "file://expand_MAKEFLAGS.patch \
SRC_URI[md5sum] = "1a11100f3c63fcf5753818e59d63088f"
SRC_URI[sha256sum] = "e2c1a73f179c40c71e2fe8abf8a8a0688b8499538512984da4a76958d0402966"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"