aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-20 23:53:12 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-20 23:53:12 +0100
commit73a227a738da17229baac142ccd889c7929402ba (patch)
tree6e48a943036b787b42b47ce32001c234325f5991 /meta
parent4a35cdda31fe083ae465423b76b06fb9bdaa691d (diff)
downloadopenembedded-core-contrib-73a227a738da17229baac142ccd889c7929402ba.tar.gz
Rename poky-lsb override to linuxstdbase
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/conf/distro/poky-lsb.conf4
-rw-r--r--meta/recipes-core/base-files/base-files_3.0.14.bb2
-rw-r--r--meta/recipes-core/glib-2.0/glib.inc2
-rw-r--r--meta/recipes-core/jpeg/jpeg_8b.bb2
-rw-r--r--meta/recipes-core/libxml/libxml2.inc2
-rw-r--r--meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb2
-rw-r--r--meta/recipes-devtools/python/python.inc2
-rw-r--r--meta/recipes-devtools/python/python_2.6.6.bb2
-rw-r--r--meta/recipes-qt/qt4/qt4.inc2
9 files changed, 10 insertions, 10 deletions
diff --git a/meta/conf/distro/poky-lsb.conf b/meta/conf/distro/poky-lsb.conf
index 64603daa63..5bc97ec16a 100644
--- a/meta/conf/distro/poky-lsb.conf
+++ b/meta/conf/distro/poky-lsb.conf
@@ -1,7 +1,7 @@
require conf/distro/poky.conf
-DISTRO = "poky-lsb"
-DISTROOVERRIDES = "poky:poky-lsb"
+DISTRO = "linuxstdbase"
+DISTROOVERRIDES = "poky:linuxstdbase"
DISTRO_FEATURES += "pam largefile"
PREFERRED_PROVIDER_virtual/libx11 = "libx11"
diff --git a/meta/recipes-core/base-files/base-files_3.0.14.bb b/meta/recipes-core/base-files/base-files_3.0.14.bb
index d8f96c0b71..857df13332 100644
--- a/meta/recipes-core/base-files/base-files_3.0.14.bb
+++ b/meta/recipes-core/base-files/base-files_3.0.14.bb
@@ -160,7 +160,7 @@ do_install_append_netbook-pro () {
mkdir -p ${D}/initrd
}
-do_install_append_poky-lsb() {
+do_install_append_linuxstdbase() {
for d in ${dirs3755}; do
install -m 0755 -d ${D}$d
done
diff --git a/meta/recipes-core/glib-2.0/glib.inc b/meta/recipes-core/glib-2.0/glib.inc
index 0319b9d04c..5ebff68a6f 100644
--- a/meta/recipes-core/glib-2.0/glib.inc
+++ b/meta/recipes-core/glib-2.0/glib.inc
@@ -29,7 +29,7 @@ S = "${WORKDIR}/glib-${PV}"
EXTRA_OECONF = "--disable-debug --enable-included-printf=no"
EXTRA_OECONF_virtclass-native = ""
-EXTRA_OECONF_poky-lsb = "--enable-included-printf=no"
+EXTRA_OECONF_linuxstdbase = "--enable-included-printf=no"
FILES_${PN} = "${libdir}/lib*${SOLIBS}"
FILES_${PN}-dev += "${libdir}/glib-2.0/include"
diff --git a/meta/recipes-core/jpeg/jpeg_8b.bb b/meta/recipes-core/jpeg/jpeg_8b.bb
index 78fabf1efd..93aa7be678 100644
--- a/meta/recipes-core/jpeg/jpeg_8b.bb
+++ b/meta/recipes-core/jpeg/jpeg_8b.bb
@@ -46,7 +46,7 @@ FILES_jpeg-tools = "${bindir}/*"
BBCLASSEXTEND = "native"
-pkg_postinst_${PN}_poky-lsb () {
+pkg_postinst_${PN}_linuxstdbase () {
if [ "$D" = "" ]; then
if [ ! -e ${libdir}/libjpeg.so.62 ]; then
JPEG=`find ${libdir} -type f -name libjpeg.so.\*.\*.\*`
diff --git a/meta/recipes-core/libxml/libxml2.inc b/meta/recipes-core/libxml/libxml2.inc
index ba6db8f2c0..d9ea816e6d 100644
--- a/meta/recipes-core/libxml/libxml2.inc
+++ b/meta/recipes-core/libxml/libxml2.inc
@@ -21,7 +21,7 @@ inherit autotools pkgconfig binconfig
EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
EXTRA_OECONF_virtclass-native = "--with-python=${STAGING_BINDIR}/python --without-legacy --with-catalog --without-docbook --with-c14n"
-EXTRA_OECONF_poky-lsb = "--without-python --with-debug --with-legacy --with-catalog --with-docbook --with-c14n"
+EXTRA_OECONF_linuxstdbase = "--without-python --with-debug --with-legacy --with-catalog --with-docbook --with-c14n"
# required for pythong binding
export HOST_SYS
diff --git a/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb b/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb
index 189c0b8746..0a7056c228 100644
--- a/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb
+++ b/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb
@@ -9,4 +9,4 @@ SRC_URI_append = "file://fortran-cross-compile-hack.patch"
ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
EXTRA_OECONF += "--disable-libunwind-exceptions"
-EXTRA_OECONF_append_poky-lsb = " --enable-clocale=gnu"
+EXTRA_OECONF_append_linuxstdbase = " --enable-clocale=gnu"
diff --git a/meta/recipes-devtools/python/python.inc b/meta/recipes-devtools/python/python.inc
index bfa0bb2b36..3de220b6a4 100644
--- a/meta/recipes-devtools/python/python.inc
+++ b/meta/recipes-devtools/python/python.inc
@@ -22,7 +22,7 @@ EXTRA_OECONF = "\
--enable-shared \
"
-EXTRA_OECONF_poky-lsb = "\
+EXTRA_OECONF_linuxstdbase = "\
--with-threads \
--with-pymalloc \
--with-cyclic-gc \
diff --git a/meta/recipes-devtools/python/python_2.6.6.bb b/meta/recipes-devtools/python/python_2.6.6.bb
index ad0d7a956a..2939df4468 100644
--- a/meta/recipes-devtools/python/python_2.6.6.bb
+++ b/meta/recipes-devtools/python/python_2.6.6.bb
@@ -5,7 +5,7 @@ PR = "${INC_PR}.1"
LIC_FILES_CHKSUM = "file://LICENSE;md5=38fdd546420fab09ac6bd3d8a1c83eb6"
DISTRO_SRC_URI ?= "file://sitecustomize.py"
-DISTRO_SRC_URI_poky-lsb = ""
+DISTRO_SRC_URI_linuxstdbase = ""
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
file://01-use-proper-tools-for-cross-build.patch \
diff --git a/meta/recipes-qt/qt4/qt4.inc b/meta/recipes-qt/qt4/qt4.inc
index de8cb691e3..b86f89f736 100644
--- a/meta/recipes-qt/qt4/qt4.inc
+++ b/meta/recipes-qt/qt4/qt4.inc
@@ -7,7 +7,7 @@ QT_ARCH := "${@qt_arch(d)}"
QT_ENDIAN = "${@qt_endian(d)}"
QT_DISTRO_FLAGS ?= "-no-accessibility -no-sm"
-QT_DISTRO_FLAGS_poky-lsb = "-sm"
+QT_DISTRO_FLAGS_linuxstdbase = "-sm"
QT_CONFIG_FLAGS += "-release -no-cups -reduce-relocations \
-shared -no-nas-sound -no-nis \