aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorJonathan Liu <net147@gmail.com>2015-09-21 21:23:44 +1000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-21 23:05:46 +0100
commit338f18e5808ea0472350d0c26edd0938ffbdcd23 (patch)
tree64c76a99c7c07cd9e50167c8795efb5a506a4011 /meta
parent16a04f25c114837e5d309a95d3841c9399b9f417 (diff)
downloadopenembedded-core-contrib-338f18e5808ea0472350d0c26edd0938ffbdcd23.tar.gz
systemd: disable problematic GCC 5.2 optimizations
This fixes systemd failing to start on Raspberry Pi 2 if it is compiled with GCC 5.2. It would try to start "Journal Service" and "udev Kernel Device Manager" but fail repeatedly. [YOCTO #8291] Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/systemd/systemd_225.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_225.bb b/meta/recipes-core/systemd/systemd_225.bb
index f7d4c7df48..4a19ff4c63 100644
--- a/meta/recipes-core/systemd/systemd_225.bb
+++ b/meta/recipes-core/systemd/systemd_225.bb
@@ -123,6 +123,9 @@ EXTRA_OECONF = " --with-rootprefix=${rootprefix} \
# uclibc does not have NSS
EXTRA_OECONF_append_libc-uclibc = " --disable-myhostname "
+# disable problematic GCC 5.2 optimizations [YOCTO #8291]
+FULL_OPTIMIZATION += "-fno-schedule-insns -fno-schedule-insns2"
+
do_configure_prepend() {
export NM="${HOST_PREFIX}gcc-nm"
export AR="${HOST_PREFIX}gcc-ar"