summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-08-30 14:49:52 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-30 22:25:20 +0100
commit3818536b556afab04f2f7d9b9e1028d498cb3926 (patch)
treef7a9c037e28097633b38b2c32397674a713048b2 /meta
parent8157c6d32e2af67211eb8fcd048a0771f10f7b26 (diff)
downloadopenembedded-core-contrib-3818536b556afab04f2f7d9b9e1028d498cb3926.tar.gz
libpsl: use python 3 during builds
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-support/libpsl/libpsl/0001-Makefile.am-use-PYTHON-when-invoking-psl-make-dafsa.patch50
-rw-r--r--meta/recipes-support/libpsl/libpsl_0.21.0.bb1
2 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-support/libpsl/libpsl/0001-Makefile.am-use-PYTHON-when-invoking-psl-make-dafsa.patch b/meta/recipes-support/libpsl/libpsl/0001-Makefile.am-use-PYTHON-when-invoking-psl-make-dafsa.patch
new file mode 100644
index 0000000000..6d6ccf4d25
--- /dev/null
+++ b/meta/recipes-support/libpsl/libpsl/0001-Makefile.am-use-PYTHON-when-invoking-psl-make-dafsa.patch
@@ -0,0 +1,50 @@
+From a0e6f0ec9dc6dd1db1c03f7f273cc16cb3af5561 Mon Sep 17 00:00:00 2001
+From: Ross Burton <ross.burton@intel.com>
+Date: Thu, 11 Jul 2019 17:47:11 +0100
+Subject: [PATCH] Makefile.am: use PYTHON when invoking psl-make-dafsa
+
+In an environment where only Python 3 is installed, configure.ac finds and sets
+PYTHON=python3 correctly but src/psl-make-dafsa is called directly, so the hashbang of
+`#!/usr/bin/env python` is used which doesn't exist.
+
+Fix this by explicitly running $(PYTHON) when using the tool.
+
+Upstream-Status: Backport [https://github.com/rockdaboot/libpsl/commit/b4fec5d0ddb70fc4f5360eb14f2f5c5e91194333]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ src/Makefile.am | 2 +-
+ tests/Makefile.am | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index f9c0a3d..a05ea05 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -19,7 +19,7 @@ libpsl_la_LDFLAGS = -no-undefined -version-info $(LIBPSL_SO_VERSION)
+ # Build rule for suffix_dafsa.c
+ # PSL_FILE can be set by ./configure --with-psl-file=[PATH]
+ suffixes_dafsa.h: $(PSL_FILE) $(srcdir)/psl-make-dafsa
+- $(srcdir)/psl-make-dafsa --output-format=cxx+ "$(PSL_FILE)" suffixes_dafsa.h
++ $(PYTHON) $(srcdir)/psl-make-dafsa --output-format=cxx+ "$(PSL_FILE)" suffixes_dafsa.h
+
+ EXTRA_DIST = psl-make-dafsa LICENSE.chromium
+
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 8b29b61..28a9a0b 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -34,9 +34,9 @@ TESTS = $(PSL_TESTS)
+ # check-local target works in parallel to the tests, so the test suite will likely fail
+ BUILT_SOURCES = psl.dafsa psl_ascii.dafsa
+ psl.dafsa: $(top_srcdir)/list/public_suffix_list.dat
+- $(top_srcdir)/src/psl-make-dafsa --output-format=binary "$(PSL_FILE)" psl.dafsa
++ $(PYTHON) $(top_srcdir)/src/psl-make-dafsa --output-format=binary "$(PSL_FILE)" psl.dafsa
+ psl_ascii.dafsa: $(top_srcdir)/list/public_suffix_list.dat
+- $(top_srcdir)/src/psl-make-dafsa --output-format=binary --encoding=ascii "$(PSL_FILE)" psl_ascii.dafsa
++ $(PYTHON) $(top_srcdir)/src/psl-make-dafsa --output-format=binary --encoding=ascii "$(PSL_FILE)" psl_ascii.dafsa
+
+ clean-local:
+ rm -f psl.dafsa psl_ascii.dafsa
+--
+2.17.1
+
diff --git a/meta/recipes-support/libpsl/libpsl_0.21.0.bb b/meta/recipes-support/libpsl/libpsl_0.21.0.bb
index fc2417fc2f..9831b4b94f 100644
--- a/meta/recipes-support/libpsl/libpsl_0.21.0.bb
+++ b/meta/recipes-support/libpsl/libpsl_0.21.0.bb
@@ -6,6 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=5437030d9e4fbe7267ced058ddb8a7f5 \
SRC_URI = "https://github.com/rockdaboot/${BPN}/releases/download/${BP}/${BP}.tar.gz \
file://0001-gtk-doc-do-not-include-tree_index.sgml.patch \
+ file://0001-Makefile.am-use-PYTHON-when-invoking-psl-make-dafsa.patch \
"
SRC_URI[md5sum] = "171e96d887709e36a57f4ee627bf82d2"
SRC_URI[sha256sum] = "41bd1c75a375b85c337b59783f5deb93dbb443fb0a52d257f403df7bd653ee12"