aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-05 17:31:32 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-03 12:35:06 +0000
commite0db1beb6db624b3b743e780c298c63a1e177cfb (patch)
tree075ab31ef8b37fd75cdd7216f86ded0dd5044e29 /meta
parent66ed6cd7e7bcce439f449c495a1ad25b1b0442d5 (diff)
downloadopenembedded-core-contrib-e0db1beb6db624b3b743e780c298c63a1e177cfb.tar.gz
nativesdk-*-provides-dummy: Fixes to allow correct operation with opkg
opkg needs the replaces/conflicts/provides in order for this package to function as intended. When enabled, this code caused failures for core-image-sato -c populate_sdk. The reason is that nativesdk-autoconf has several perl dependencies. We need to list more of the things which this package provides/conflicts with in order for it to function correctly. Therefore add the missing entries. (From OE-Core rev: 27412b377dda47daa87bfcb3a41babe53ff8b0a3) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/meta/dummy-sdk-package.inc4
-rw-r--r--meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb22
-rw-r--r--meta/recipes-core/meta/nativesdk-sdk-provides-dummy.bb1
-rw-r--r--meta/recipes-core/meta/target-sdk-provides-dummy.bb27
4 files changed, 50 insertions, 4 deletions
diff --git a/meta/recipes-core/meta/dummy-sdk-package.inc b/meta/recipes-core/meta/dummy-sdk-package.inc
index eafcb823ab..4d653706b1 100644
--- a/meta/recipes-core/meta/dummy-sdk-package.inc
+++ b/meta/recipes-core/meta/dummy-sdk-package.inc
@@ -20,7 +20,7 @@ PR[vardeps] += "DUMMYPROVIDES"
python populate_packages_prepend() {
p = d.getVar("PN")
d.appendVar("RPROVIDES_%s" % p, "${DUMMYPROVIDES}")
- #d.appendVar("RCONFLICTS_%s" % p, "${DUMMYPROVIDES}")
- #d.appendVar("RREPLACES_%s" % p, "${DUMMYPROVIDES}")
+ d.appendVar("RCONFLICTS_%s" % p, "${DUMMYPROVIDES}")
+ d.appendVar("RREPLACES_%s" % p, "${DUMMYPROVIDES}")
}
diff --git a/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb b/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
index f5bcb82548..6a8748acdf 100644
--- a/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
+++ b/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
@@ -2,7 +2,27 @@ DUMMYARCH = "buildtools-dummy-${SDKPKGSUFFIX}"
DUMMYPROVIDES = "\
nativesdk-perl \
- nativesdk-perl-module-file-path"
+ nativesdk-libxml-parser-perl \
+ nativesdk-perl-module-bytes \
+ nativesdk-perl-module-carp \
+ nativesdk-perl-module-constant \
+ nativesdk-perl-module-data-dumper \
+ nativesdk-perl-module-errno \
+ nativesdk-perl-module-exporter \
+ nativesdk-perl-module-file-basename \
+ nativesdk-perl-module-file-compare \
+ nativesdk-perl-module-file-copy \
+ nativesdk-perl-module-file-find \
+ nativesdk-perl-module-file-glob \
+ nativesdk-perl-module-file-path \
+ nativesdk-perl-module-file-stat \
+ nativesdk-perl-module-getopt-long \
+ nativesdk-perl-module-io-file \
+ nativesdk-perl-module-posix \
+ nativesdk-perl-module-thread-queue \
+ nativesdk-perl-module-threads \
+ /usr/bin/perl \
+ "
PR = "r2"
diff --git a/meta/recipes-core/meta/nativesdk-sdk-provides-dummy.bb b/meta/recipes-core/meta/nativesdk-sdk-provides-dummy.bb
index 11a727d486..b891efa5ef 100644
--- a/meta/recipes-core/meta/nativesdk-sdk-provides-dummy.bb
+++ b/meta/recipes-core/meta/nativesdk-sdk-provides-dummy.bb
@@ -4,7 +4,6 @@ DUMMYARCH = "sdk-provides-dummy-${SDKPKGSUFFIX}"
DUMMYPROVIDES = "\
/bin/bash \
/usr/bin/env \
- /usr/bin/perl \
pkgconfig \
libGL.so()(64bit) \
libGL.so \
diff --git a/meta/recipes-core/meta/target-sdk-provides-dummy.bb b/meta/recipes-core/meta/target-sdk-provides-dummy.bb
index 714d15d8ba..edf07c4a23 100644
--- a/meta/recipes-core/meta/target-sdk-provides-dummy.bb
+++ b/meta/recipes-core/meta/target-sdk-provides-dummy.bb
@@ -1,6 +1,33 @@
DUMMYARCH = "sdk-provides-dummy-target"
DUMMYPROVIDES = "\
+ busybox \
+ coreutils \
+ bash \
+ perl \
+ perl-module-re \
+ perl-module-strict \
+ perl-module-vars \
+ perl-module-text-wrap \
+ libxml-parser-perl \
+ perl-module-bytes \
+ perl-module-carp \
+ perl-module-constant \
+ perl-module-data-dumper \
+ perl-module-errno \
+ perl-module-exporter \
+ perl-module-file-basename \
+ perl-module-file-compare \
+ perl-module-file-copy \
+ perl-module-file-find \
+ perl-module-file-glob \
+ perl-module-file-path \
+ perl-module-file-stat \
+ perl-module-getopt-long \
+ perl-module-io-file \
+ perl-module-posix \
+ perl-module-thread-queue \
+ perl-module-threads \
/bin/sh \
/bin/bash \
/usr/bin/env \