aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-03-02 14:16:05 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-02 14:21:05 +0000
commit97056011c17f343e697aa9f0d418f6487b9f7465 (patch)
tree3b5badcd840fcb17e9d96c83115181ad201b1125 /meta
parent0116e4814aa55feb0f8944deb98e39b4534bab0c (diff)
downloadopenembedded-core-contrib-97056011c17f343e697aa9f0d418f6487b9f7465.tar.gz
meta-estsdk-toolchain: use WORKDIR instead of D to hold locked-sigs
do_locked_sigs() uses ${D} to hold a file as input to the sstate staging code. Generally this isn't a problem as it happens after packaging, but sometimes (if the recipe is rebuild, perhaps) do_package() will see the file inside ${D} and fail because there is an uninstalled file. Solve this by using a directory under ${WORKDIR} so it can't be packaged. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/meta/meta-extsdk-toolchain.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/meta/meta-extsdk-toolchain.bb b/meta/recipes-core/meta/meta-extsdk-toolchain.bb
index 0b8fcf08dc..235d6ecc0f 100644
--- a/meta/recipes-core/meta/meta-extsdk-toolchain.bb
+++ b/meta/recipes-core/meta/meta-extsdk-toolchain.bb
@@ -10,7 +10,7 @@ do_populate_sysroot[deptask] = "do_populate_sysroot"
# within sstate.bbclass, so if you copy or rename this and expect the same
# functionality you'll need to modify that as well.
-LOCKED_SIGS_INDIR = "${D}/locked-sigs"
+LOCKED_SIGS_INDIR = "${WORKDIR}/locked-sigs"
addtask do_locked_sigs after do_populate_sysroot
SSTATETASKS += "do_locked_sigs"