aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2012-02-29 21:27:07 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-01 09:35:32 +0000
commit0889f693916bb8f77003af419f71212201b4d9c9 (patch)
tree696958f4a56aac95a00e92ae52693db1bb7c23f3 /meta
parent8054497b393d40a2ed8c802c74a02e92a3001297 (diff)
downloadopenembedded-core-contrib-0889f693916bb8f77003af419f71212201b4d9c9.tar.gz
linux-libc-headers-yocto: bump to v3.2.8
Making two changes for BSPs that prefer linux-libc-headers-yocto: - bumping to v3.2.8 headers - stubbing out unecessary linux-yocto functions when headers are being built [YOCTO #2032] Acked-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb29
1 files changed, 19 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
index 734170f843..7aa932224f 100644
--- a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
+++ b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
@@ -8,12 +8,13 @@ DEPENDS += "unifdef-native"
PROVIDES = "linux-libc-headers"
RPROVIDES_${PN}-dev = "linux-libc-headers-dev"
RPROVIDES_${PN}-dbg = "linux-libc-headers-dbg"
-SRCREV = "69cfbdf9f1ff461a75e5b77d6d7ba35e97db4cc3"
-PV = "2.6.37+git-${SRCPV}"
-PR = "r4"
+SRCREV = "21ab5dca134a6bf1316aa59f69f9ee9e091d5702"
+KBRANCH ?= "standard/base"
+KMETA ?= "meta"
+PV = "3.2+git-${SRCPV}"
+PR = "r5"
-SRCREV_FORMAT = "meta_machine"
-SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.37;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.2;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
# force this to empty to prevent installation failures, we aren't
# building a device tree as part of kern headers
@@ -35,6 +36,16 @@ do_configure() {
oe_runmake allnoconfig ARCH=$ARCH
}
+do_install() {
+ set_arch
+ oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
+
+ # The ..install.cmd conflicts between various configure runs
+ find ${D}${includedir} -name ..install.cmd | xargs rm -f
+}
+
+# The following tasks are not required when we just want
+# headers. So we override and stub them out.
do_kernel_configme() {
}
@@ -44,12 +55,10 @@ do_patch () {
do_compile () {
}
-do_install() {
- set_arch
- oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
+do_validate_branches () {
+}
- # The ..install.cmd conflicts between various configure runs
- find ${D}${includedir} -name ..install.cmd | xargs rm -f
+do_kernel_configcheck () {
}
BBCLASSEXTEND = "nativesdk"