aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2012-03-02 18:34:19 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-02 12:24:40 +0000
commit0725c7f01b173b1cc2090f4a03a274c7017b8a1a (patch)
tree02062bc3dcb9d180b266a48473e1df1313b0f083 /meta
parentaaab6ae94258277dcd2f29823a64689e6245fa7a (diff)
downloadopenembedded-core-contrib-0725c7f01b173b1cc2090f4a03a274c7017b8a1a.tar.gz
V2 Fix libpam's chmod
The libpam's has an error when generating the rootfs: chmod: cannot access `/usr/sbin/unix_chkpwd': No such file or directory This is because the following code in libpam_1.1.5.bb: pkg_postinst_pam-plugin-unix () { # below is necessary to allow unix_chkpwd get user info from shadow file # on lsb images chmod 4755 ${sbindir}/unix_chkpwd } This is to set the setuid permission for unix_chkpwd (the lsb test requires this), but it lacks a "${D}", and we can do this in the install stage. [YOCTO #2049] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/pam/libpam_1.1.5.bb9
1 files changed, 3 insertions, 6 deletions
diff --git a/meta/recipes-extended/pam/libpam_1.1.5.bb b/meta/recipes-extended/pam/libpam_1.1.5.bb
index 283f477eb9..8dd5ac5251 100644
--- a/meta/recipes-extended/pam/libpam_1.1.5.bb
+++ b/meta/recipes-extended/pam/libpam_1.1.5.bb
@@ -9,7 +9,7 @@ SECTION = "base"
LICENSE = "GPLv2+ | BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=ca0395de9a86191a078b8b79302e3083"
-PR = "r2"
+PR = "r3"
SRC_URI = "https://fedorahosted.org/releases/l/i/linux-pam/Linux-PAM-${PV}.tar.bz2 \
file://99_pam \
@@ -85,10 +85,7 @@ do_install() {
install -d ${D}${sysconfdir}/pam.d/
install -m 0644 ${WORKDIR}/pam.d/* ${D}${sysconfdir}/pam.d/
-}
-pkg_postinst_pam-plugin-unix () {
- # below is necessary to allow unix_chkpwd get user info from shadow file
- # on lsb images
- chmod 4755 ${sbindir}/unix_chkpwd
+ # The lsb requires unix_chkpwd has setuid permission
+ chmod 4755 ${D}${sbindir}/unix_chkpwd
}